Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Problem With Radio - On But Not Working (http://www.wranglerforum.com/f282/problem-with-radio-on-but-not-working-30210.html)

JeepMikey 05-06-2009 09:02 AM

Problem With Radio - On But Not Working
 
Currently the issue with my stock CD player in my 05 wrangler is that it's as if the buttons weren't working. The radio's clock displays, but the power or no other buttons work in order to power the radio on. Eject also doesn't work, and I have a CD inside of the player.

I tried to disconnect the battery and let it sit for about five minutes in order to reset, but still the same issue.

Has anyone had this problem in the past? Hate to have to buy a new radio when this one was working fine up until now...

JeepMikey 05-06-2009 10:00 AM

anyone?

stevens243 05-06-2009 10:02 AM

It sounds like you:

Have a bad ground to the radio, or

Have a short, or

Have a radio you can throw away.

Pull the radio, check the connections on the back and the ground wire that connects to the firewall. While there, look for stripped wire etc.

IF that doesn't change anything, see if you can find a place that will diagnose the radio for free/cheap.

Jma20a 05-06-2009 11:38 AM

if its not the ground and is a problem with the unit just upgrade to a new headunit, something that has more features, like a built in ipod interface, an other inputs and out puts. if you do end up getting a new one find one you like on crutchfield that is a little over your price range and then go on ebay and see what kind of deals they have. i saved close to $700 for all my upgrades and stuff.

DM_MKV 10-04-2010 04:14 PM

Quote:

Originally Posted by Jma20a (Post 368325)
if its not the ground and is a problem with the unit just upgrade to a new headunit, something that has more features, like a built in ipod interface, an other inputs and out puts. if you do end up getting a new one find one you like on crutchfield that is a little over your price range and then go on ebay and see what kind of deals they have. i saved close to $700 for all my upgrades and stuff.

Sorry to bump old topic but Just purchased a 04 rubicon and this happened to me. Grounds check out and so do fuses. Any other suggestions. Eject works on mine however nothing else does. Just displays time if I press the Time Button.

Jerry Bransford 10-04-2010 04:25 PM

See if you have a little tiny hole somewhere near the CD player which is where a pin is inserted to manually release the CD if one is stuck. A stuck CD can cause the radio not to work. I used to have the same radio but I don't recall if it has that CD release hole or not.

If you can not get it working and want a replacement for an '04 Rubicon, PM me as I have the OE unit from my '04 Rubicon out and sitting on a shelf in my garage.

And a big welcome to WF DM MKV. :)

Jeepillac 10-04-2010 04:34 PM

Same issue here. My radio works fine, but the CD player doesnt play or eject the CD in it. Im pretty sure mine stopped working after I got caught in a storm with my top down.

DM_MKV 10-04-2010 05:07 PM

Quote:

Originally Posted by Jerry Bransford (Post 801956)
See if you have a little tiny hole somewhere near the CD player which is where a pin is inserted to manually release the CD if one is stuck. A stuck CD can cause the radio not to work. I used to have the same radio but I don't recall if it has that CD release hole or not.

If you can not get it working and want a replacement for an '04 Rubicon, PM me as I have the OE unit from my '04 Rubicon out and sitting on a shelf in my garage.

And a big welcome to WF DM MKV. :)

Quote:

Originally Posted by Jeepillac (Post 801974)
Same issue here. My radio works fine, but the CD player doesnt play or eject the CD in it. Im pretty sure mine stopped working after I got caught in a storm with my top down.

Thanks all! I can get the cd out that is all that works it wont play or turn on anything. Just looked for a reset hole no luck. I am going to stop by the dealer and see what they say. If not I will probably just get an aftermarket one.

Thanks again.

Derek

DM_MKV 10-05-2010 11:50 AM

Quote:

Originally Posted by DM_MKV (Post 802007)
Thanks all! I can get the cd out that is all that works it wont play or turn on anything. Just looked for a reset hole no luck. I am going to stop by the dealer and see what they say. If not I will probably just get an aftermarket one.

Thanks again.

Derek


Update:

It was a ground. :bottom:

ky_ace 06-26-2011 09:00 PM

resurrecting an old topic, but can you tell me what ground it was? Mine started the same thing yesterday and I'd like to get it working again..


All times are GMT -5. The time now is 10:06 AM.