Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Some electrical issues that are driving me bonkers (http://www.wranglerforum.com/f218/some-electrical-issues-that-are-driving-me-bonkers-30538.html)

wrangle4me 05-12-2009 01:26 PM

Some electrical issues that are driving me bonkers
 
Hi, I'm new on the forum, and I know it's bad form to just post away, but I have been searching everywhere and my problem still seems unique. If someone can point me to a pre-existing thread I missed I'll be happy to take it there, but in the meantime:

Recently bought an 89 YJ with the 4.2. Mechanically it's sound, everything worked good when I bought it, frame is good, needed bs work that I like doing anyway, and the price was right.

So I notice the brights are on when I'm driving it home from where I bought it, and I click the switch, and no low beams. Ok, whatever, flip the highs on and rock it home.

One day I'm killing some beers with a friend and we decide to take it down my land at night....start her up and no lights or radio. Turn signals still work. Since then I've been checking for shorts, connected two completely loose grounds in the engine bay, and been going insane. It looked like a wire that tied into a square-ish plug right next to the steering column was burned up so I replaced those and still nothing. Fuses are good. Has an aftermarket cd head unit.

Now the annoying thing here is that I was going down the road one day during the day, and I repeatedly try to turn on the radio, and it came on in 4th gear, but instantly turned off when I clutched in to shift. Happened a couple times. Just now going to get food the radio came on when I started it in my garage briefly then off, then on again then off, then stayed off. This points to a ground somewhere in my mind, but I'm not sure where to go from here. I've been looking at the chilton's and wiring stuff is really hard for me to comprehend for some reason so before I go completely insane is there a specific place to check? Is there a common ground for headlights and radio? If anyone can give me a hand it would be greatly appreciated.

NAVYCHIEF 05-12-2009 01:44 PM

look up under the dash where the clutch pedal is. there may be a wire bundle being affected by the pedal.

wrangle4me 05-12-2009 02:31 PM

Negative. Just checked that thoroughly. Also, no brake lights. Don't know why I forgot to mention that.

NAVYCHIEF 05-12-2009 02:45 PM

in front of the battery there are relays. have you looked at them. some are interchangable. check them for corrosion.

wrangle4me 05-12-2009 03:39 PM

Done and done, little bit of gunk on the relays, sanded and sprayed to make sure they are really clean, the connector terminals looked pretty good. Still no dice. Thanks for the help by the way.

NAVYCHIEF 05-12-2009 06:19 PM

not a problem. keep an eye out here. we'll get er done.:punk:

ccain 05-12-2009 07:12 PM

It may seem like a lot of work, but I would start by looking at every ground, even the one that grounds the body to the chassis. tighten and and or replace every one. Also, if it's an after market radio, it may benefit you to remove it completely and make sure it's wired correctly. Again, might seem like a pain in the butt, but if the previous owner of your Jeep was retarded like the previous owner of mine, God knows what kind of mess you'll find behind the dash. I honestly don't know what kept my Jeep from burning to the ground before I rewired the whole damn thing. :D

Then, if you still have issues, check the headlight switch, dimmer switch and the rolling dimmer that dims the dash lights next to the headlight switch. Always start cheap and work up to the pricey stuff.

Good luck!

wrangle4me 05-13-2009 12:33 PM

Ok I'm going through the grounds and now I have a question about a fusible link. I Grounded it out on the frame when it was just dangling, it ties into what I guess is the dash wiring, it connects in right behind the battery and disappears into the firewall there. This is the only fusible link I see. I tried tying it to power and no good on anything that way either. I noticed the gauge panel is not working either, I know it did when I bought the car. I am terrible with this electrical stuff so please bear with me.

P.S. I didn't know it was a link at first, I thought it was an engine ground for some reason. My mustang basically blew up on me the other night so I've got motors go around in my head making coo coo clock noises.

And also, ccain, when you say check the switches you me to check whether they are getting power with a test light correct? just yank the plug and test with key on? last thing, body to chassis grounds are all over or what? not sure where to look and if you can save me from going crosseyed looking at chiltons I would be grateful. Sorry if I'm being a huge jackass here.

buckshot500 05-13-2009 09:49 PM

Easy way to solve the grounding issue.

Go to the nearest big box parts store & get 4 or 5 ground straps (braided), they are cheap too.

Ground the battery to the tub, (right behind the battery) then find the battery ground wire. It should ground to the block. Unbolt it, then clean it & the block. From that bolt, run a strap to the frame & one to the alternator case.

Next, go under the dash & ground the frame of the dash to the tub. If you can grab the metal that holds the speedo, tach etc. this would be better.

I have even read where it's good to run a dedicated ground wire, from the alt case to the speedo ground terminal.

Above all, clean any connections thoroughly ( take off any paint with sandpaper) & use dielectric tune up grease to seal everything up.

wrangle4me 05-13-2009 10:18 PM

soooo...definitely going to look into the grounding issue, thanks buckshot.

However, starting to think it's not a ground. Link I found= stereo subwoofer something or other? anyhoo it's nothing to do with anything necessary.

Here's the real clinker: been diving into the chiltons this evening and looking through diagrams and all. What I have found here is this:

I'm getting power to about half my fuses in the fuse block. Most of the fusible links are completely gone and just tied in with wires. There is a small rectangular box (if you are looking from the grillstraight in) to the bottom right of the battery that had two, count 'em two, positive leads off the battery tied into it. One was completely good and tied in and all, the other was tied into a red/red wire from the battery and barely hanging on on this little rectangular piece. Basically what to take away here is that half my fuse block seems to be getting power and that I found a power wire near the battery that doesn't seem to really be connected to anything. Ripped it off and everything still runs the same. This probably had a plow or winch at one point.


Synopsis: I spent 9 hours at a desk, then came home, pulled heads on a modular mustang, then started playing with electrical on a jeep i'm not familiar with. Forgive me for this wired post. I'll clear anything specific up in the morning.

wrangle4me 05-13-2009 10:22 PM

P.S. buckshot I will be grinding down to metal with a dremel and securely grounding all that shit tomorrow thoroughly to make sure. I'm getting this damn thing done within a week. Hooah.

buckshot500 05-13-2009 10:24 PM

The small box, is it on the firewall? If so, this is the starter relay.

You'll want to put all the fusible links back, since they are the only thing between you & lots of fire should anything go wrong.

I just posted in another member's thread about this:
http://www.wranglerforum.com/f8/88-y...ion-29867.html

The Chilton's diagrams can be pretty helpful, once you understand what your looking at!

I think they are even direct copies of the "Factory Service Manual" drawings.
Link;

http://www.scribd.com/doc/5114189/Je...iring-Diagrams

wrangle4me 06-01-2009 09:36 AM

alright got a new one for everyone. Got it wet the other day and pull into my garage and turn off the key and the damn thing stays on. Where to even start with this one?

buckshot500 06-01-2009 09:29 PM

OK the relays on the battery holder are for the intake manifold heater, & the electric choke.

I'm not sure where the headlight relay is, but suspect it's under the dash.

As for the new problem, it may be the ignition switch or the resistance wire that feeds the coil.

Fact of the matter is, you need better help with this one.
I don't see him listed on this board, may be here & going by another name.

I know you can find JunkYardGenius at http://www.jeepsunlimited.com
He hangs on the CJ forum. Mind your manners around him, & he can be a huge help. I remember him talking about why the key sometimes won't shut off the ignition. Just can't remember what thread.

He also has a website;
http://junkyardgenius.com/


.

wrangle4me 06-15-2009 02:11 PM

Electrical is taken care of. Was a combo of issues but got it taken care of today minus the non turning off. I guess on that I'm gonna start with the ignition switch and then head towards the control module.

Thanks for all the help and support guys.


All times are GMT -5. The time now is 11:11 PM.