Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ General Discussion Forum (http://www.wranglerforum.com/f290/)
-   -   Instrument cluster lights (http://www.wranglerforum.com/f290/instrument-cluster-lights-32439.html)

Jon H 06-23-2009 09:02 PM

Instrument cluster lights
 
I recently noticed that the lights that light up the instrument cluster don't work. I've pulled it apart and looked it over the best I could and found nothing. All of the other lights work fine its just the lights for the instrument cluster that don't work. I looked at the fuses and there are a couple blown that I will replace shortly( I did swap them out with good fuses but got nothing) but I don't know which circut the lights are on. I tested all the lights and they work fine, and after that I unplugged the cluster and tested the wire that should provide power to the lights but got nothing with the ignition on and switch on. Does anyone have any ideas for me to try before I start pulling the wiring apart?
Thanks

birdhunter 06-23-2009 09:23 PM

Pull dash, pull clean and greese conections
as needed

NAVYCHIEF 06-23-2009 11:02 PM

try looking at the thumb wheel next to the light switch.

elbringit 06-24-2009 04:55 PM

play with the thumb wheel, unplug blow out connectors and replug i had my 93 yj parked outdoors in sandy conditions for about ten years without moving it and i have had to do this with most of my connections

Jon H 06-24-2009 05:11 PM

I talked to a guy who owns a shop today and he printed me off a wiring diagram and he says it looks like the lights are dependant on 2 fuses so I will check both. After that I will go to the thumb wheel and clean the connections.


All times are GMT -5. The time now is 10:17 PM.