Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   No spark - CPS? (http://www.wranglerforum.com/f218/no-spark-cps-34470.html)

JB208 08-07-2009 02:54 PM

No spark - CPS?
 
Hi all,

I'm looking to pick some knowledgeable Jeep brains. My 93' Wrangler quit after I put it in reverse (manual trans) before I let out the clutch. The stall resembled electrical failure. No start now. No spark from the ign. coil. Gauges aren't working. Back up lights aren't working. All other electrical seems to work. Checked fuses and they seem to be ok. I was wondering if it couldn't be the CPS. My repair manual suggests that, along with several other wiring problems. Any advice? Thanks for your time.

JB

yjwes 08-07-2009 04:33 PM

could be a cps fuel pump run?

JB208 08-07-2009 04:39 PM

Thanks for the reply. I just checked it and the fuel pump is not running. I had the power on and no fuel pump sound, or pressure on the fuel rail port.

yjwes 08-07-2009 08:04 PM

check all your fuses. it cranks with the key?

JB208 08-07-2009 09:14 PM

It does crank with a key. I'll dig into the fuses more tomorrow. The fuses in the power distribution center next to the battery appear fine. I checked all the fuses that can be pulled out. I'll look at the ones on the inside under the dash tomorrow.

Is there anything else that it could be, other than the CPS or a fuse/ short in a wire? The symptom that is tricky to me is that it was idling fine until I put the gear in reverse (manual tranny). It stalled immediately and hasn't started since. It's almost like there is a sensor in the tranny that effects fuel and spark.

jpdocdave 08-07-2009 10:34 PM

i was all on board for cps till the fuel pump. cps will usually be no spark, and no injector pulse, but fuel pump will still prime at key on, and power to pump is not controlled by cps. it is effected by ignition switch though, do the warning lights come on the dash for the first few seconds the key is on? if not thats a tell tale sign of switch.

JB208 08-07-2009 11:21 PM

Warning lights do not come on. I didn't notice that before. So no warning lights, no gauges, no back up lights. No spark, no fuel pump, no fuel rail pressure. All other controlled electrical components seem to work (head lights, break lights, turn signal, radio, and wipers). Tomorrow I'll test the ignition switch.

Could a faulty ignition switch cause all of my symptoms?

jpdocdave 08-08-2009 05:13 PM

yep, sounds like the switch. other parts will still work, and the starter can still crank, they're on different pins on the switch being powered up.

be sure to post updates.

JB208 08-08-2009 11:54 PM

I pulled a relay out from under the dash today and swapped it with the one that runs my horn in the power distribution center. The Jeep started right up. Then I swapped the relays back so they are in their original places. The Jeep started right up. I guess that relay needed to be re-set, if thats possible. I am still skeptical that I could have a short somewhere. The previous owner left a mess of wires behind the dash that hang down a bit. I'll have to dig into that after a while. For now, I'll pick up another relay to have just in case this happens again. Thanks to all for their input. I'm just happy to be playing in the Jeep again. My little boys were happy to go for a ride today also.

zhenke 08-10-2009 06:01 PM

Hey JB208,
I have a '92 that I am having similar problems with. What relay did you replace? Any help would be appreciated.

93yjsplash 08-10-2009 06:08 PM

happened to me i pulled something that was not labled as anything pertaining to the fuel pump to try in my dash lights scoket and then was baffled when it wouldnt start. I listened for fuel pump and nothing so i retraced my steps and remembered i had pulled that fuse put it back and started right up

zhenke 08-16-2009 05:18 PM

I just replaced my crankshaft position sensor, and it fired right up. Woohoo!

ShoreToRun 08-31-2009 06:41 PM

I am having the exact same problem with my 97 Wrangler. Where under the dash did you find the relay? I can only find one relay to the bottom right of the fuse panel on the passenger side of my vehicle and it is not the same as my horn relay, so I don't think its the same one you are talking about.
Kenney

93yjsplash 08-31-2009 09:54 PM

ShoreToRun

You should post in the TJ section of the forum,they could probably answer your question better there.

Welcome to the forums :)


All times are GMT -5. The time now is 02:07 PM.