Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   no power to fuel pump (http://www.wranglerforum.com/f218/no-power-to-fuel-pump-34784.html)

minderbinder3 08-12-2009 09:26 PM

no power to fuel pump
 
My 1991 YJ 2.5 suddenly died yesterday. It has spark, but no fuel pressure and the fuel pump doesn't come on at all. I checked the voltage to the fuel pump it doesn't have any. I checked another similar Jeep it had 7+ volts going to the fuel pump. I checked and changed all the relays and still nothing. It has power going into the power box (where the relays are) and I cleaned all the terminals and grounds I could find on the firewall just above the power box and battery. Any suggestions?

Captaincoop1220 08-12-2009 09:49 PM

the same thing happened to me a few years back, it turned out to be a bad ground wire. i ended up cutting it and running a new ground. good luck

minderbinder3 08-12-2009 10:17 PM

You talking about 1 of the three wires that run to the connector for the fuel pump or is there another ground somewhere?

wbrett1027 08-12-2009 10:33 PM

try fuses or reley

skeeter 08-12-2009 10:35 PM

You'll only have power to the fuel pump for a second or so when you hit the key.
Have someone else turn the key while you watch the tester.
Also, make sure you're testing the right wire, it's really frustrating to spend a bunch of time looking for an electrical problem only to find out you were testing the gauge wire :redface:

minderbinder3 08-13-2009 07:04 AM

You were right. Once I test the connector while someone turns the key...I get a flash of power similar to the other Jeep's. I have checked all fuses and relays and they seem fine. The reason I am wondering if it really is the fuel pump or not is because it did not give any warning when it stalled. It did not act like it was fighting for fuel or anything, but either way there is no fuel at the TB.

whitebuffalo 08-13-2009 08:57 AM

i just went through this. jeep was running fine one minute and then died and wouldnt restart unless i gave it some ether. on mine, the prefilter/sock/strainer thing that is on the end of the fuel pump basically imploded and went into the fuel pump. the pump is around $140 iirc.

skeeter 08-13-2009 11:22 AM

fuel pump at shucks auto

minderbinder3 08-13-2009 02:34 PM

Autozone has each (screw on and snap on) of the fuel pumps in stock for under $90, so I'm going to pull it and then see which one I need. I am also going to replace my filler tube while I'm there because mine has some cracking. I had to order it from the dealership but it was only $20. Thanks for your help and I will post my results.

minderbinder3 08-14-2009 09:54 PM

All's good. I replaced the fuel pump today and she fired right up. It wasn't too bad I bought the pump from Autozone for $81.99, as well as a new strainer for $11.99. I could not see anything visibly wrong with the other one but something apparantly went bad. Getting the tank down and out and then in and up was a bit of a struggle, but after I cut the rusty bolts off the skid plate it only took me a couple of hours. My tank is poly and surprizingly clean on the inside and I cleaned up the connectors on the sending unit while I was there. She idles better now...however my fuel gauge no longer works. Any ideas? By the way...thanks for all your help on this one. It feels good to have her back on the road.


All times are GMT -5. The time now is 03:00 AM.