Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Jeep Wrangler Sport 03 Cluster Malfunction. (http://www.wranglerforum.com/f210/jeep-wrangler-sport-03-cluster-malfunction-35527.html)

Nano 08-26-2009 08:26 PM

Jeep Wrangler Sport 03 Cluster Malfunction.
 
I apologize for the length of this post but would appreciate some help. I'm not big into the inner workings of vehicles in general, so pardon my ignorance. I have only started into looking into the inner works of my jeep because of the current issue.

I have recently had my Jeep repaired to do an accident caused by someone else. About within a couple weeks after getting the Jeep back I went offroading and at the end of the day I noticed an issue with the gauge cluster, the temporary dome lights that comes on at ignition(not the #4 fuse connect to the door defeat switches), rearview mirror Direction/Temperature display and my Fog Lights.

The gauge cluster will drop power, all dials will drop to 0 and all displays go out, then most lights will come back on like when the Jeep is first started. The main issue is that the fuse is blown, so nothing should work at all. I can only assume there is a cross somewhere between the fuse and the guage cluster. If there are any other possibilities, suggestions or opinions, I would love to hear them.

The temporary dome light system seems to malfunction in line with the gauge cluster. Are those also handled by the same fuse/connection?

The rearview mirror direction/Temperature display is acting up separately from the gauge cluster in that it is blank normally, yet it comes on/displays when the break is pressed. Any ideas?

My fog lights don't come on at all now. I hadn't used them since getting the Jeep back from the repair shop.

I'm not sure if these issues are due to the offroading, though I don't see any mud behind the dash at all, or if these are due to a shotty repair job or lack of attention to detail. The shotty repair/lack of attention to detail come to mind because I got the Jeep back without it being fully finished. The Jeep was returned to me with the door locking mechanism not replaced(bent in driver side door collision), the passanger side door defeat switch compression knob is missing, and the Jeep was returned to me with the windshield wiper container bone dry(which I don't think can happen due to the hose pulling the liquid out is about a half an inch above the bottom of the container, and they would have had to have taken the container out to repair/replace the panel).

I would appreciate any info, knowledge, suggestions and opinions about my situation.

4Jeepn 08-26-2009 08:32 PM

not sure, but some folks have had similar issues with the dash guages, there should be main bunch of wires If I recall... try to see if any are lose or only part in etc..

Nano 08-26-2009 08:44 PM

Quote:

Originally Posted by 4Jeepn (Post 429981)
not sure, but some folks have had similar issues with the dash guages, there should be main bunch of wires If I recall... try to see if any are lose or only part in etc..

Yeah, I saw a thread with a similar issue, but it didn't suggest that the fuse was blown. From my very limited knowledge, almost nothing on the gauge cluster should show up at all if the fuse is blown. Did any other threads you notice say the fuse #10 was blown but the gauge cluster still speratically worked? I haven't searched high an low here yet, sorry.


All times are GMT -5. The time now is 03:05 AM.