Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ General Discussion Forum (http://www.wranglerforum.com/f290/)
-   -   Bought my first Jeep 88 Wrangler (http://www.wranglerforum.com/f290/bought-my-first-jeep-88-wrangler-370234.html)

MusicMan88 11-01-2013 08:45 PM

Bought my first Jeep 88 Wrangler
 
I recently got an 88 Wrangler. Somebody swapped the stock carb out for a Motorcraft. I'm not sure what model because I've yet to find any numbers. I've read that this is a common practice but I'm having problems. It will start but won't hold idle. As long as I keep it "revved up" it will run. All this Jeep stuff is new to me. I've worked on Chevys for years..trucks,.muscle cars and dirt track cars. Will a Holley 2300 "bolt up" to a 4.2 Engine ?? and does the original carb that would have came from the factory have and electric choke ??

Any help/ideas would be appreciated.

Beastmaster 11-01-2013 08:49 PM

Welcome to the forum! :wavey:

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)


Click here for helpful tips for newcomers

Wranglin4Life 11-01-2013 10:53 PM

Sounds like the carb may need some adjusting/cleaning. Welcome and congrats!

OregonPlinker 11-01-2013 11:57 PM

How many rpms is "revved up"? Welcome aboard!!

BCDonny 11-02-2013 01:26 AM

welcome and the motorcraft works very well on the jeeps

MusicMan88 11-02-2013 04:55 PM

Thanks for all the Welcomes !!....The problem is definitely the carb. it runs as long as I "pat the gas" and keep the RPM over 1000. The accelerator pump is working and the float isn't stuck. I took the jets out and sprayed carb cleaner through them. Must have some build up or trash in it somewhere. No matter what I do I can't get it to idle.

harleydragon 11-02-2013 06:52 PM

if it only does it when it's cold then sounds like the choke is not working..if it is doing it all the time then you probably have a vacuum leak


All times are GMT -5. The time now is 01:56 AM.