Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   The "I strongly dislike the PO of my jeep" rant (http://www.wranglerforum.com/f19/the-i-strongly-dislike-the-po-of-my-jeep-rant-38305.html)

ExDementia 10-19-2009 07:06 PM

The "I strongly dislike the PO of my jeep" rant
 
Warning: Long rant ahead, if you want to skip the BS I have a question down at the bottom marked by the bold print.

I'll start with just a bit of background info, the previous owner of my Jeep was some college girl who knew nothing about Jeeps so her dad did all the modifications to it for her. From the crappy stereo/amp installation to the cheapest lift he could get his hands on, he did everything half-assed and cheap as possible. BTW the reason I bought this Jeep is because it had low miles and was about 2K under bluebook.

First annoyance: The Stereo
The girl's dad put an amp under the rear seat (otherwise completely uncovered) and ran the wires under the carpet securing them with a mixture of scotch and duct tape.:banghead: Then put a sub in the "trunk" which took up 80% of the little bit of space there was. This being a young "O.C." college girl's Jeep, the top was down A LOT. So the amp and sub were ruined at some point, I'm guessing by rain.

Fairly recently someone tried to steal my stereo but after ripping out the center piece of my dash they still couldn't get it out, so they settled for my faceplate and my MAG light. Great!:)

This prompted me to change out the stereo for a pretty decent Sony Xplod unit. After about 20 mins of trying to get the stereo out of the dash, (I can see why the thieves had so much trouble) I pull it out to find a mess of electrical tape and wire splices.:mad: All the wires were cut so short I could only hold the stereo about 2" away from the dash. Between the wire length, and a capped off extra wiring harness(wtf?) left back there, I could tell this was not the first aftermarket stereo to be installed.

So I take off all the electrical tape, look up what each color wire goes to coming off the harness, then remove all the crap wiring they put in. I was also about to prepare the interior for my hurculining job I was about to do so I pulled out the broken amp and all the speaker wiring taped to the tub (I had a good time scrubbing all the duct tape residue off the tub too!).

Then I install my new stereo the CORRECT way by labeling the wires, and splicing the wires all in the same place to make for a very clean installation. I also found that while they replaced the in-dash speakers with some pretty decent Alpine speakers, they didn't even wire them into the amp or stereo! So they had just been sitting there all this time...:confused: Anyway, maybe its because they hadn't been used all this time, but the rubber around the edge of the speaker became pretty brittle and was starting to break off after using them only for a few days. I found a pretty good deal on some new Sony ones at walmart so its fine now. Then I put in my soundbar and I'm pretty much all set in the audio department now after all that bullsh*t work.:cool:

Second annoyance: Lift kit and tires
He put in a super cheap 4" Skyjacker kit with only the bare minimum needed. I read that the shocks on this kit were horrible and break pretty quick, so this explains the one thing he did right, Rancho 9000's (I'm guessing one of the shocks blew which made him buy these).:doh:

So the components are now the stylish faded pink, with a super cool transfercase drop (didn't spring for an SYE so now I have to) and now-sagging coils. I spray painted the T-case drop black when I was removing the front driveshaft so that at least looks better.

Along with the lift they went up to 33's, only 4 though, no matching spare tire or rim, just the stupid stock one on the back.:mad: (I took it off though, it was useless.) They also didn't regear afterwards leaving the stock 3.07 ratio in there...:9lame:

Here's my question:
So now I read that with anything over a 2-3" lift you need extended swaybar links. I thought before it was just recommended. They have been on there with no problem since the lift was installed, I can tell I was the first person to disconnect them.

Is this going to give me problems? I was going to wait a bit for QC's because I wanted to get other stuff first but should I move this up to the front of the list?

Thanks in advance

Schmo 10-19-2009 08:12 PM

Yeah with a 4" lift you should really have extended links.

At least it didn't have a 3" BL!!! :D

little1989jeep 10-19-2009 08:21 PM

least you have a running jeep with a radio

ExDementia 10-19-2009 08:22 PM

So what exactly is wrong with having the stock links? They aren't hard to connect or anything, and it rides fine:confused:

tiny terror 10-19-2009 08:25 PM

It's dangerous to leave them disconnected at high speeds and the links too short put the sway bar at the wrong angle and it'll bind.

ExDementia 10-19-2009 11:08 PM

Quote:

Originally Posted by tiny terror (Post 463364)
It's dangerous to leave them disconnected at high speeds and the links too short put the sway bar at the wrong angle and it'll bind.

I know its not safe to drive on the freeway with them disconnected but the rest of what you said confused me a little:redface:

distortedtj 10-19-2009 11:15 PM

The factory links are designed to position the sway bar at a certain angle. When the height of the suspension is heightened the sway bar is no longer going to be at the correct designed angle. Putting it into a bind.

distortedtj 10-19-2009 11:17 PM

The factory spec angle for the sway bar is a 10* up angle. Just a FYI.

ExDementia 10-20-2009 12:19 AM

Ah, I see, and what will this binding do? is this something I am experiencing now? Or is it just a risk?

mrcarcrazy 10-20-2009 08:33 AM

I feel your pain. My jeep came with a walmart special headunit. They didn't even bother with wire butt connectors. they just twisted the wires together and wrapped it in a mess of E tape. It was also wired incorrectly. I'm shocked it worked at all...but now I see why it was so intermittent in its operation.

My PO also stole my jack and tools, so when one of the tires went flat in my parking lot due to a bad sidewall, I was screwed.

They also only bough 4 31'' tires. leaving the factory (flat) 30'' tire.


I feel your pain.


on the binding. if it occurs your sway bar will become a ineffective spring...(endlinks will likely be bent)

ExDementia 10-21-2009 05:02 PM

Ok so, what I've done so far: (The cheap stuff)

Stereo: Fixed - All new deck, speakers, and wiring. (A good 3 hours cleaning up they're mistakes)

Tub: Mostly fixed - Sanded off the light rust, and covered up all the stupid holes the PO put in the tub for some unknown reason, then hurculined.

Outside ugliness: Half fixed - Spray painted the super faded fender flares, removed the also faded milk jugs, got a new top, spray painted the faded license plate bracket, removed the useless dinky stock spare tire, painted the stupid T-case drop, and spray painted the headlight bezels.

What I still need to do: (The expensive stuff, which is why I haven't done them yet)

Drivetrain: Need a SYE (good bye T-case drop), need a CV driveshaft, need to fix my front drive shaft so I can have 4wd again, need to find some kind of replacement for my rear axle at least, and I need to regear to 4:56's.

Suspension: Need new coils.

Wheels and tires: Need a full size spare.

Interior: Need seat covers (or new seats), need to replace the cracked, faded, door panels, and new upper door skins.


:9lame:

nicolas-eric 10-21-2009 05:18 PM

You're on a long way that will never end...

jdhallissey 10-21-2009 06:01 PM

Umm most of that I know were to find for decent prices like always I will continue my search.

ExDementia 10-21-2009 06:04 PM

Quote:

Originally Posted by jdhallissey (Post 465312)
Umm most of that I know were to find for decent prices like always I will continue my search.

And all information you have passed on to me of these prices has been extremely helpful:D

buckshot500 10-21-2009 09:03 PM

Well even though I'm a musician & a music lover, I tossed my radio & never put anything back in. I kinda like the hole in the dash where it used to be. Lets me reach in to fiddle with wires & such.

As for the other stuff, it sounds like it's pretty standard fare for buying a used jeep.

I had to go through most of mine to get it working right.


All times are GMT -5. The time now is 02:03 PM.