Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   tick...tick... (http://www.wranglerforum.com/f282/tick-tick-38603.html)

toplessartist 10-24-2009 01:00 AM

tick...tick...
 
I have a sporadic and non-steady ticking noise coming from the fusebox area (behind the glove box) It ticks *waits a couple four seconds* tick *waits two seconds* tick *ten seconds* tick ... in other words it isn't steady and it isn't consistant, but it sounds like a relay or a switch. It only happens on my '03, not on my '00. Everything works and I haven't blown any fuses or had any malfunctions. Been doing that since I got it (year and 3 months) and I kinda tune it out. I'd rather fix it.

Anyone? Bueller?

Thanks
Chris

csamn2007 10-24-2009 04:35 AM

LMAO Bueller.

I would check for any loose wires and all grounds. No dimming lights when it ticks?

wranglersteve 10-24-2009 09:18 AM

I have the same thing. Only when the heat or defroster is on. I have checked everything. Don't know what it is.........??

motokeen 10-24-2009 09:23 AM

Yep. Same here but its randomn. DOesn't do it to often.

stevens243 10-24-2009 09:45 AM

One of your relays is getting weak. The armature is supposed to be open (or closed) and is closing (or opening) for just a minute until the coil opens it back up.

It's probably for something you aren't using at the time that has power available.

When it's doing it, try touching the relays and you should be able to feel it snapping.

Ensure you have something more than 12v to 13.6v on the battery and if you do, replace that relay.

hishamsTJ 10-24-2009 11:16 AM

i think stevens243 is right also check if ur main belt is rolling well i hade same problem and i checked everything was fine i ve changed main belt and sound of tick tick disappeared

motokeen 10-24-2009 12:21 PM

My belt has been squeeling to so maybe I'll check both.


All times are GMT -5. The time now is 05:32 PM.