Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   oil leak (http://www.wranglerforum.com/f210/oil-leak-3925.html)

mrbigjeep 11-13-2006 09:27 PM

oil leak
 
ok just an update on the oil leak (posted thread couple weeks ago)

well anyway i took it to the dealer like yall said since its under warranty. well they said they tightened the plugs (on the engine or something like that) and that should fix it. it didn't. took it back again and picked it up today after they tole me it was the plugs again. once again it didn't fix it. drove about 5 miles or less and looked under there and yep it was still leaking. the guys at the dealership are freakin' retard idiots. i don't even know if the retards know where the leak is comin from. its coming from between the transmission and a black box thing under the jeep (the box has a head [bolt] on the end)
maybe this is the oil pan? well its between the black box and the tranny and i don't even know if the idiots know its coming from there. we dropped the keys off and my dad just wrote "oil leak" as the problem and i asked if we should write where its coming from and he said no but i guess we should have because the guys at the dealership were obviously too stupid to find it. anyway i have to take it back again for the 3rd stinkin time and this time i'm telling them ITS COMING FROM BETWEEN THE TRANSMISSION AND THE OIL PAN

so anymore ideas? that black box is the oil pan isn't it? anyway they couldn't fix it.

JeepGuyLJ 11-13-2006 10:15 PM

Bigjeep i have the same problem. This is exactly what they said inspection found small seepage at oil drain plug and oil pan gasket/// retorqued oil drain plug cleaned oil at pan & oil pan no active leak found at this time. The people who work there are really retards i came home and after 2 days i look under the jeep and i see that their is a leak so i think i have to take it in again its a pain in the ass. Let me know how it gos yeah thanks.

1BLKJP 11-14-2006 03:00 PM

All I can say is keep after them Bigjeep, because it's probably one of two things. Either the valve cover is leaking in the rear of the engine and it's running down or the rear main seal is leaking. The first isn't too big a deal to replace on your own. The second is a pretty big pain in the ass. You are under warranty and they need to fix it right.


All times are GMT -5. The time now is 09:43 PM.