Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   97 wrangler no start got spark no power to fuel pump (http://www.wranglerforum.com/f210/97-wrangler-no-start-got-spark-no-power-to-fuel-pump-41345.html)

97rangler 12-15-2009 01:38 AM

97 wrangler no start got spark no power to fuel pump
 
so here it is hope your in for a long one. drove the jeep to work it didnt start when i went to go home. checked all the relays ADS fuel pump all that jazz and replaced the ADS. As for the fuel pump relay it was fairly new already. I have searched online for others with this problem and have heard every fix under the sun. All the relays, grounds, power to PD box. I replaced the fuel pump it works i tried it! I bypassed the relay by adding a jumper to the relay from the battery and the fuel pump came on, sure enough the thing starts and runs. if i put the relay back in it just cranks and the pump doesn't come on:banghead: The only thing that i think is weird is the steering wheel doesn't lock anymore. I am wondering if something broke in the column and isnt sending the right signal to the PCM to tell it to let the pump come on... I dunno sounds weird, but it is a jeep. I replaced the CPS a while back about 10000't miles ago. I have heard that the CPS has a lot to do with letting the ECU work other systems. I tried hooking up an OHM meter to (CPS) and it didn't register, dont know if im an idiot or if the CPS is really not working properly. I know that all these systems need to work properly in order to let is start and run. Here is my idea bypass the relay with a switch and new relay and d direct wire the pump, so all I have to do is turn on the switch and the pump will run! is this a good idea? has anyone done this before? Wish i had the money to drop in a new motor and harness and get rid off all the crap crysler put under the hood............PLEASE HELP ME im loosing my mind:banghead:again still banging my head

rrich 12-15-2009 03:31 AM

Your title says no spark too. Is that the case, or is it just the pump not working. Yes, it does make a difference in the direction you take.

I assume you disconnected the CPS connector when you used the Ohmmeter on it. Not sure, but I think the CPS should read somewhere around 100 Ohms.

If it's lacking both spark and pump, it's PCM related, just pump it's in the pump/relay circuit. We need to know.

Update - just found a site that says the CPS should be 125 to 275 Ohms - warm. Cold shouldn't be much more.
Essentially it's just a coil of wire around a magnet.

If needed, get the CPS from the dealer - it's the current version and not much more expensive, if at all. Parts houses are still selling old ones, and the discount places are selling Chinese knock-offs. I've had bad luck with the knock-offs.

97rangler 12-15-2009 03:52 AM

this is hard to explain so bear with me. there is spark, it will run if i jump from the battery to the plug in the power distribution box. if the relay is plugged in it will not start. it cranks over like a champ. I just took a volt meter to the plug that plugs into the harness for the pump above the rear axle. it read 5.4 volts, so i guess it has power to it, just maybe not enough. i originally tried it with a test light and it did not light up that is why i thought that it didnt have power. as far as the amount of ohms, my ohm meter shit the bed and i am using one im not to familiar with, so ill check up on it and repost after i check how many ohms the CPS is putting out, thanks for helping!!!

97rangler 12-15-2009 04:17 AM

also it threw this code p1389 No Auto Shutdown (ASD) Relay Output Voltage At PCM so i replaced the ASD that code has since gone, but i still have the problem

mudslinger150 12-15-2009 08:58 AM

why are you posting the same thing in multiple threads that are duplicate threads...?

rrich 12-15-2009 11:13 AM

The relay box - power distribution box - under the hood - sometimes the underside gets corroded. You can see how it comes apart. Get to the underside where the wires attach to the sockets.
You can use a spray electrical cleaner to clean it up - or -- I haven't tried it on the box - if it's really green with corrosion, use Taco Bell's hot sauce - mild - to dissolve the green. It sounds weird, but it works. (try dipping an old penny in it - and we eat that stuff!)
Use the spray cleaner after the taco sauce to wash off and neutralize the acid.

It may be just a bad connection.

97rangler 12-15-2009 02:55 PM

sure will try it im lost as to why this is happening.

97rangler 12-15-2009 04:19 PM

i guess i feel like a tool, but its running now i cleaned the shit out of all the connections with electric cleaner and a wire brush. sure enough damn thing started i guess it was the cleaner that did it. thanks for the help with the idea i am glad to see jeepers helping jeepers. much thanks


All times are GMT -5. The time now is 03:17 PM.