Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   A/C & Defrost Problem (http://www.wranglerforum.com/f210/a-c-and-defrost-problem-42234.html)

burton160w 01-03-2010 07:43 PM

A/C & Defrost Problem
 
So my air conditioner and defrost has been having a problem lately. I have commented on it before, but here's the rundown.

1) The car squeals LOUDLY starting up if the A/C or defrost is on for only about 10 seconds. I finally attributed this to the a/c compressor.

2) The defrost, blower, and a/c only work on high.

3) Their is a popping sound that can be heard when the defrost is first turned on.

4) The defrost doesn't always turn on first time, and often only air blows out of the front air vents, not the top, and makes a horrible squeal different from number one.

:crash: Any suggestions? Obviously my air compressor has gone as per number one, but I have no idea what all needs to be done to fix it. The swap itself is fairly easy from what I have read, but there are other things to be done I don't know about. And then what about problems 2-4, the air compressor does not necessary explain those issues.

terrible2 01-03-2010 09:00 PM

atleast youre not without AC in Hawaii. Im sweating and its even winter.

MTWanderer 01-03-2010 09:14 PM

The most common reason for having only the low and highest blower motor speed is a Blower Resistor that has reached the end of it's life.

Not an expensive part (around $20) installs behind the glove box, though it is easiest to reach from under the dash (Easy is a relative term)

Search on Blower Motor Resistor .. I found the topic well covered.

burton160w 01-05-2010 11:18 AM

UPDATE! While I haven't looked at the resistor yet, now my Jeep's blower won't turn off when the key is out of the ignition!


All times are GMT -5. The time now is 10:53 PM.