Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   MidWest Regional Forum (http://www.wranglerforum.com/f49/)
-   -   Bad Fuel Milage after Alabams cylider head (http://www.wranglerforum.com/f49/bad-fuel-milage-after-alabams-cylider-head-44198.html)

defensesix 02-09-2010 10:22 AM

Bad Fuel Milage after Alabams cylider head
 
I just replaced the head on my 01 wrangler. I replaced the oil pump with a melling high volume, The head is an Alabama Cylinder head,New water pump exhaust,gaskets and an AEM intake kit. This wrangler was getting 14mpg to 18 mpg respectively before the head was replaced. It is running around 115 miles per tank less than before now. Also it does not want to "kick" down in to passing gear at highway speeds. I have had this cable adjusted by two shops it still does not shift right. Any Ideas???? My range was around 320 miles per tank now it is around 140 miles per tank. New plugs etc were also installed tach is dead on at idle. It was turned to top dead center when the head was installed also.

defensesix 03-09-2010 10:03 AM

Hey I got this figured out!!! the spacers were installed WRONG for the AEM intake kt they were on the top, instead of on the bottom to raise the controls for the kick down cables because there is a spacer under the throttle body! his thing runss BADD A.. Now!

KawiTJ 03-09-2010 10:39 AM

Quote:

Originally Posted by defensesix (Post 566228)
Hey I got this figured out!!! the spacers were installed WRONG for the AEM intake kt they were on the top, instead of on the bottom to raise the controls for the kick down cables because there is a spacer under the throttle body! his thing runss BADD A.. Now!

i like when i figure things out:doh:.....:D good job


All times are GMT -5. The time now is 04:37 AM.