Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Water pump adventure (http://www.wranglerforum.com/f218/water-pump-adventure-45012.html)

Raptorclaws 02-22-2010 02:20 AM

Water pump adventure
 
ok, so I was on my way back to school today and i was on the highway. I started smelling smoke, i looked at my temperature gauge and the needle was about to break the gauge it was so hot. So i quicky got on the shoulder and turned my car off. Found out my water pump completely failed and drained my radiater fluid out. I'm lucky the engine block didnt crack, then I got towed the rest of the way to school. So all in all, i need to replace the water pump soon. Does anyone have any advice to give me?

brent in az 02-22-2010 07:35 AM

Replaced mine 4 days ago. Came to 216---inexpensive. $68 for the napa pump; the rest for labor.

I noticed it dripping from undercarriage after I got off the highway. I knew from experience it was only the water pump--in other words it didn't fall off like yours. My temp/engine never got hotter.

My advice is get it fixed. If you want to DIY, then get a book. Blades, pulleys, pumps, belts all have to come off the front end. There's worse projects.

ashevilleyjmike 02-22-2010 07:38 AM

I just did mine this weekend....twice! I dont' think I gave the RTV enough time to set and it leaked after replacing everything. So, I did it all again (waiting 24 hours) and will check today to see if it works.

I went ahead and replaced the belt, thermostat, and theromstat housing since you are already in there you might as well.

PM me if you have any questions on the install.

brent in az 02-22-2010 07:41 AM

Quote:

Originally Posted by ashevilleyjmike (Post 552818)
I just did mine this weekend....twice! I dont' think I gave the RTV enough time to set and it leaked after replacing everything. So, I did it all again (waiting 24 hours) and will check today to see if it works.

I went ahead and replaced the belt, thermostat, and theromstat housing since you are already in there you might as well.

PM me if you have any questions on the install.

Ha! That's what happened when I did it the 1st time in another jeep! Wrong RTV and not enough time! (different jeep).
This time I "found" the 200.
I botch a lot of projects the first time...

ashevilleyjmike 02-22-2010 08:19 AM

What is the 200 you're talking about?

I used the red RTV stuff first...the stuff I use on my diff's. I then found out they make specific water pump sealant. If it leaks today, I'm going to cry.

brent in az 02-22-2010 08:24 AM

$200 bones---I put in in the hands of the pros this time.

Yes, you need special rtv for the water pump.

Last time I did my diffs I just used the black stuff. You supposed to use the red rtv for diffs?

ashevilleyjmike 02-22-2010 08:41 AM

Uh, I'm not sure. That's just what I bought at the auto parts store. Probably just a different brand hence the coloring. Works for me.

cpaul3 02-22-2010 09:03 AM

not a bad job to do if you want to save money..did mine no problems since.. from the water pump that is

CP


All times are GMT -5. The time now is 02:54 PM.