Jeep Wrangler Forum

Jeep Wrangler Forum (
-   Communications and Electronics (
-   -   New Radio Unit...Now AC Doesn't work? HELP! (

Rawb77 03-01-2010 11:18 PM

New Radio Unit...Now AC Doesn't work? HELP!
Hey guys, got a bit of a dilemma I was hoping I could get some help on before going back into the Stealership.

Went to a certified auto guy who does custom work and had him install a JVC 820 radio unit. Had to hook it up via a converter box of some sorts to basically make it so the output is in the plug style from the vehicle to the radio unit. A common thing that happens with installation of radios.

I noticed afterwards that my AC was not working properly. The 2 buttons in the center of the AC section of the console were not lighting up when pressed. If I turned on the air the vehicle would always run in the cycle mode (as I could tell with a soft top that the vehicle windows and roof did not "pop out" as usual)

I also noticed that I could toggle the AC compressor with the button to either run in fan mode or to run cold air, although the light was out you could tell that it was working because cold air would blow through and then stop when pressed again.

Checked all the fuses and even disconnected the battery, nothing wrong or fixed with that.

Took it into the dealership. They diagnosed it as a bad AC control unit (the computer behind the console) They got the part in today so I brought in my Jeep...They replaced it in about 1 hour and no luck at all.

They then asked me about my radio and that "there's a bunch of wires back there where you've had your radio installed and we need to make sure thats not the problem else fixing it will cost you money"

I told them I needed the vehicle for work and since it is still cool weather out, I will bring it back in when I have a free weekend since I have no other vehicle.

Anyways....anyone have any idea what may have caused this? Is it indeed the radio? I wouldn't think that the vehicles AC controls...somehow run with the radio cables....? I know the guy that installs these radios does several of them a week and knows what wires to connect and whatnot...that and he has installed in a Jeep before (my coworkers Jeep) and he doesn't have a problem with his.

Any guesses? I'm all ears.

P.S. Also forgot to add that the Electronic compass doesn't show up on the dash anymore. We tried putting the stock radio unit back in with origin wire set up exactly as it comes difference, still not working.

s3nt3nc3d 03-01-2010 11:31 PM

Sorry I can't help...but it sounds like the installer didn't exactly know what he was doing and screwed some connections up. I'm honestly not sure on that one though... might try making sure all your connections are good and tight. He may have knocked stuff loose while installing the radio.

Rawb77 03-01-2010 11:39 PM

All connections are good. We double checked them, and the dealership checked them twice so far in their attempts to see if it was the AC control unit/computer that went bad.

The guy I took the Jeep into has done these installs before...

Gone Broke 03-01-2010 11:46 PM

Nothing special about the connector, you pretty much need them for all radio installs unless you want to do a lot of cut and splice. The area I would be concerned with is where the aftermarket radio harness hooks into the adapter. You do have to splice here and he could have accidentally shorted something out. I know on my 03 TJ I have 2 accy wires in the ignition. One runs the HVAC, and the other runs the radio. When I put in my remote start it took a while to figure out why the radio would play but the ac would not come on. He may have disconnected the secondary aux wire by mistake thinking he didnt need it. Just guessing here, but if it worked before he messed with it and now it don't...Well I think you can figure out the rest..

Gone Broke 03-01-2010 11:48 PM

honestly I would take it all out, inspect each wire, even the ones he didn't touch, and start all over again.

Rawb77 03-01-2010 11:58 PM

Thats not a bad idea. I do believe there may have been a wire or two he may have not needed to use. I know one for sure was a wire for a power Antenna. Not sure if there were any others but there's always that possibility.

Something went awry when the install happened. What I dont understand is if it was by chance one of those wires...why didnt the AC work properly when we put the stock unit back in with the stock set up (took out the adapter and just ran the wire bundle from the vehicle to the stock radio unit) All the fuses are good in the fuse box. We double then triple checked them.

I think you may be on to something with the wires though...

Both lights are off. AC toggle still works...Cycle doesnt turn off...always on cycle if air is moving. Could be a second wire ...*sigh* i dunno

Gone Broke 03-02-2010 12:04 AM

If your selector is set to defrost it will engage your a/c without showing the light. If you turn it to vent, or max a/c with the blower on and the a/c light does not light then you have an issue. Go beyond the radio harness and pull out the hvac harness. Look for anything that may have run through the radio harness. I'm not meaning to the radio, but through the plastic loom the wires come in.

Gone Broke 03-02-2010 12:04 AM

Let me see if i can find my alarm wires. They gave the color of the aux wires..

Gone Broke 03-02-2010 12:05 AM

Nevermind, they are at home. I can bring them tomorrow and let you know what I find

Rawb77 03-02-2010 07:42 AM

Found out what the problem is this morning. Turns out it was an issue with a fuse. Haha...rather funny but annoying at the same time.

No it wasnt burned out....It was in the wrong slot. The stealership the first time I brough it in I remember now them telling me they had replaced a fuse related to the AC/Compass but that it still wasnt working after that.

I checked that fuse this morning. M8 and M34 are right next to each other. M8 refers to heated seats...M34 is related to HVAC/Compass. Take a guess where that fuse was seated. Yeah........I dont have heated seats.

Made the swap before going on my commute. Turned her on...OMG LIGHTS! and CABIN PRESSURE!!!!11!1!!

All times are GMT -5. The time now is 04:25 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.