Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   electrical problem??!! (http://www.wranglerforum.com/f218/electrical-problem-4591.html)

YJ93 12-17-2006 10:28 PM

electrical problem??!!
 
My 93 has developed some kind of electrical fart, can quit figure it out.
The turn signal indicator on the dash is staying lit (left arrow) when the headlight switch is turned on, and yes all of the bulbs are good! The side marker light is very very dim, just barely glowing. W/ the ignition on all turn and hazard lights work fine. With the ignition off, if you switch the turn signal to the left, the dash indicator light turns of and the light returns to normal birghtness. Turn the switch off and the side marker light goes back very dim, and the turn signal indicator in the dash comes back on.
I have checked the wires running from the socket to the fire wall and all looks fine, the socket itself looks fine, and I cleaned the contacts. Same goes as far as the wiring from the fire wall to the headlight switch, cleaned the contacts, also the same with the wires up to the point where the harness plugs into the turn signal switch on the steering column.
#1 is it safe to assume that the turn signal swith is fine, since the problem only occurrs when the lights are turned on?
#2 I had a leak from the windsheild cowling that ended up dripping down around the parking brake release (very close to the headlight switch), so could it be that switch, as the problem only occurrs when the switch is on?
#3 or last but not least, is it more likely that there is a ground problem, or a small section of the wire to the light that the insulation is worn causing a short? (or would that be an all or nothing situation where it is either shorted or not, not just very dim)
Ideas or suggestions very welcome, knowing my luck lately the poor little guy will burst into flames!:(

amerijeep 12-17-2006 10:32 PM

You either have a ground problem or a bad bulb. I know you said all your bulbs are good, but how do you know? Just because they work doesn't mean that one isn't a problem.

YJ93 12-18-2006 08:09 AM

As far as the bulbs go, I went ahead and changed them (least expensive option to start with).
Last night I went ahead and pulled the headlight switch, cleaned all of the contacts, put it back in.
Going to work this morning the thing had the fart again when I first left out, but after driving for a little bit it went back to normal. Crossing my fingers and hoping its resolved!:rolleyes:

amerijeep 12-18-2006 11:12 AM

Good luck. I'm always good for an electrical conundrum.

4Jeepn 12-18-2006 11:30 AM

I had a car that had sort of the same issue. The head lights would go out at certain times. Then if you wanted to make a left turn you had to turn the windshield wiper ons to get the signal to work. I have usually found that most jeep realted problems are as amerijeep said, a bad ground.

YJ93 12-18-2006 12:18 PM

Thanks Guys!
Hopefully I will have a picture of my little mudpuppy on here soon. It has had many mods other than drivetrain as of yet (daily driver).
But it is definately my baby!


All times are GMT -5. The time now is 10:52 AM.