Jeep Wrangler Forum

Jeep Wrangler Forum (
-   YJ Tech Forum (
-   -   wont start, problem with the fuel pressure? (

jubilee 03-08-2010 04:39 PM

wont start, problem with the fuel pressure?
i was driving my 92 YJ to school the other day when it started to sputter. i pulled into a parking lot, turned it off, and checked fluids and leaks but there was nothing wrong.

a week later, with a new fuel pump, a new fuel filter and new fuel hose, it still wont start.

chilton says that the gas pressure should be around 39 psi. so when i check the pressure on the fuel rail, shouldnt it spray out? it barely leaks out

what are some other things i could try?

Garyk 03-08-2010 05:04 PM

Check the fuel regulator

jubilee 03-08-2010 10:24 PM

where is the furl regulator located at?
how do i check it?

minderbinder3 03-09-2010 06:34 AM

It should be about 39 while its running. You can only check it with fuel gauge. It will only trickle out when not running.

tlrrob1000 03-09-2010 09:36 AM


Originally Posted by jubilee (Post 565908)
where is the furl regulator located at?
how do i check it?

At the end of your fuel rail towards the fire wall. It is the round thing with a vacuum line going to it. Pull the vacuum line off. If it has fuel there and is wet in any way it is bad.

pilots_are_gods 03-14-2010 06:18 PM

This seems to be the exact issue i am having with my 92, just changed the pump and filter and it still won't start. As soon as the weather clears up I'll see if this solution works for me.

brent in az 03-14-2010 06:34 PM

I thinkin other side of the vehicle: fuel injection(?).

Garyk 03-14-2010 06:46 PM

I would check some of the sensors out .
Maybe its me but in most of the "won't start " or "runs for awhile then quits" threads, it turns out to the computer....just a thought.

pilots_are_gods 03-15-2010 10:41 PM

ya i'm pretty stumped as to why mines not starting. Just installed a new pump and filter cause I was under the impression that was why it wasn't starting, but it still hasn't solved my problem. Pulled the fuel lines off at the rail and cranked it and nothing was coming out. It's a 4.0 and hopefully whatever is causing this doesnt involve dropping the tank again....big pain. Any advice will do, just wanna get this damn thing running.

minderbinder3 03-15-2010 10:51 PM

When you turn the key on do you hear the fuel pump come on? If not check your relays under the hood.

pilots_are_gods 03-15-2010 11:07 PM

ya I checked the relay, it was fine, just wondering how noticeable the fuel pump is when its on.

minderbinder3 03-16-2010 06:39 AM

You will hear a noticeable hum for about 2 seconds when you turn the key.

pilots_are_gods 03-16-2010 09:07 PM

ya thats def a big negative on the fuel pump coming on, slowly i'm getting to the source of the problem

Garyk 03-17-2010 05:03 PM

Jubilee, have you checked for ignition?

renegadewarrior 03-19-2010 09:47 AM

Could be a computer problem, try this to check: turn on the key and listen do you hear the fuel pump prime? if not leave the key on and keep listening if you hear relays starting to click then the fuel pump primes, it is two capacitors on your computer board that cost less than 5 bucks and if you can solder you can replace them yourself. It may take a couple minutes before the relays start to click so grab a beer turn the key on and just sit there and listen. If this is the problem do a search on some forums for ecm problems and there are some detailed instructions out there on how to fix this. It is a very common problem.

thatch68 09-13-2010 10:19 AM

Fuel Pump continuously running on 1990 YJ
I just replaced the fuel pump and filter. When you take off the air handler and look at the injector, it is not dropping any fuel out of the injector, but I can hear a small gurgling sound coming from within the throttle body.

I the Jeep has been sitting it will crank right up, but if you turn it off it won't start. It seems to be flooding out.

Might be a fuel regulator? Anyone have any thoughts.

snakeroo 09-20-2010 02:13 PM

I seem to have this same problem on my 1993 Wrangler. Last night I was really low on gas and then seemed to have run out of gas. Had to pay $10 for a stupid 1 gallon can. Put that in and still no start. Put a bottle of fuel injector cleaner in. It turned over for a second, it seemed, then died. Got another gallon of gas, put it in, still no luck. Put another bottle of fuel injector cleaner in, and for a second thought it was starting, but no. Checked all the fuses under the dash and also the ones in the box by the battery. All test ok for continuity. Then I realized I wasn't hearing the "buzz" sound of the fuel pump? when turning the key to On. Bled the test port valve on the fuel rail, VERY tiny bit of air came out. Tried to start, sound same as when i had put the bottles of injector cleaner in, no luck. I then noticed a small plastic air? hose, near the fuel rail, completely severed. One end goes into the top, rear of the cylinder head, 6 inches behind the oil cap. And the other end goes to a sensor. Looking in the book, it seems to be the sensor next to the Manifold Air Temperature Sensor. Taped it up best I could, but still no start. After 6 hours in the parking lot, exhausted, I left it on the street and trekked home.

Read another thread that said to check the fuel pump ground by the emergency brake. But where is that? By the brake pedal? or where the emergency brake goes into the rear drum?? I can't seem to find the fuel pump either? On my old (87) YJ, it was in the engine compartment. Where is it on my 93? Also can't see to see where the book tells me the name of the sensor that severed air hose goes to?

snakeroo 09-21-2010 04:12 PM

So my Jeep still won't start. I've tried replacing the fuses under the dash. I tested all the fuses (except the square block type) in the box by the battery for continuity and they are good. I noticed the block fuse labeled "horn" and the one next to it labeled "fuel pump" were identical. So I swapped them. The horn still worked, but still no buzz/prime sound from the fuel pump when I turn the key to On. And it still does not start. I put about 5 more gallons of gas in and turned the key to On, leaving it there for like 1 or 2 mins, hoping maybe the fuel pump would pull the fuel. But nothing. I am at a loss. I did take down the error code message numbers(after doing the thing where you turn the key to On, then Off, then back on..about 7 times). And the series of numbers for the code is: 1 2 3 3 5 5. How do I find out what error this code represents? And any other ideas for things for me to try? Help? =o/

crtaylor 09-22-2010 08:20 PM

Jeep Horizons :: 1991-1995 Jeep Wrangler (YJ) Trouble Codes heres the codes you need

snakeroo 09-23-2010 02:09 AM

Thanks, the page doesn't load. But I found the codes elsewhere. Mine is code 33. And i DO have an AC. So apparently the code is for the 02 sensor. But talking to a Jeep dealer, they said the 02 sensor error code is totally separate and not the cause of my issue. To review, I turn the key to On and NO familiar hum from the fuel pump. But instead, 1 single click(I presume from the relay in the box by the battery). No fuel reaching the injectors. Is this a candidate for the 3 capacitors in the ECU?

Other possible thoughts: Crank sensor(on bell housing?), Air flow sensor(dunno where?), Ignition control module(dunno where?), wire harness to the ECU? Recheck the fuel pump ground strap where it is connected to the frame(rear driver wheel?)

snakeroo 09-24-2010 05:54 AM

Rubber mallot to the gas tank, with the key to the ON position for the win!!!

gord420 04-19-2011 05:40 PM

hey guys im havin a simalar problem i have a 92 wrangler 2.5l and i was driving it around the yard when it kinda spit and spuder then quit so i thought gas! put gas in still nothing i can hear my pump prime and im geting fuel at the rail so my next guess was ignition! pulled a plug and wasnt getin spark so i checked cap and rotor seemed fine! so i left it 4 the day! came back next day and it fired rite up ran 4 about 10 min then quit. so i asked a buddy and he said coils sometimes get hot the screw up so i put a coil on the next day then same thing ran 4 a few min then quit???????? im kinda lost. i went and got a haines manuel and they say something about a crankshaft position sensor so i went and priced 1 and they want like a 150 bucks 4 it and thats at cost so was wondering if anyone could help me thanks gord

POS YJ 04-19-2011 05:51 PM

I keep a crank sensor, cam sensor and coil in my box for spares. Those are really the only things that can go wrong with the ignition, unless the ECM goes out. My cam sensor gave me the same symptoms as you have. It is in the distributor and easy to swap out. That would be my guess as my coil and crank sensor both killed the Jeep permanently, the cam sensor was intermittent.

gord420 04-19-2011 06:04 PM

cam sensor is that the same thing as a stator??? that is in the distributer???

gord420 04-19-2011 06:24 PM

have u had this problem many times??? or do u just keep the spare parts 4 a " just in case" kinda thing???? thanks 4 ur help

POS YJ 04-19-2011 06:25 PM

The cam sensor is located under the distributor cap. Remove the cap, then the rotor, and there will be a black plastic piece which covers the innards of the rest of the distributor. That is the cam sensor, it will have a wire or two coming off of it. Call your local parts stores for prices, the price you saw for the crank sensor seemed quite high.
Edit: Sometimes I throw parts at my Jeep instead of properly diagnosing it. If I guess wrong, then the good old parts go in the bag. I also save plugs, wires, cap and rotor. The plugs got a 3.0 Toyota off the hill one night, even though it ran like poop.

gord420 04-19-2011 06:31 PM

Ya ok thanks 4 the info. And yes i thought that price was a bit high 2 even 4 up here in canada. anyways thanks 4 the help and ill post my results

ellery 01-20-2012 01:51 AM

try taking the gas cap off i have a 93 yj with the 2.5 in it and im having problems as well i have replaced many a sensors and i have extremely high fuel pressure at the rail and it will randomly stall on me as well i have found if i take the gas cap off and relive the pressure in the tank it will start right up im going to check my fuel regulator and see if that fixes the problem and the return line

anamorph 01-21-2012 09:17 PM

I had the same problem. It's your fuel regulator. It should be located on the fuel rail somewhere. I have a 4.0 so I couldn't tell you where it is on a 2.5.

All times are GMT -5. The time now is 01:16 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.