Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ General Discussion Forum (http://www.wranglerforum.com/f290/)
-   -   Newbie with a question (http://www.wranglerforum.com/f290/newbie-with-a-question-46266.html)

kijloy 03-10-2010 12:41 PM

Newbie with a question
 
I bought an 88 YJ. I've never owned a Jeep but I bought it on a buddies insistance that it was a good deal. I'm still convinced that it was and I like the fact that I'm gonna have to probably rebuild the entire engine. the problem I'm having is that I'm more of a shady tree mechanic rather than a trained mechanic. I'm not sure if this is even the right forum for my questions (not that I don't have confidence in WF's collective intelligence). So i guess my question is " Is this the right forum to get help with technical troubleshooting questions." Who knows, my questions might not even be that technical, but they seem it to me. Thanks in advance for any help.

Cons_Table 03-10-2010 12:45 PM

Quote:

Originally Posted by kijloy (Post 567510)
I bought an 88 YJ. I've never owned a Jeep but I bought it on a buddies insistance that it was a good deal. I'm still convinced that it was and I like the fact that I'm gonna have to probably rebuild the entire engine. the problem I'm having is that I'm more of a shady tree mechanic rather than a trained mechanic. I'm not sure if this is even the right forum for my questions (not that I don't have confidence in WF's collective intelligence). So i guess my question is " Is this the right forum to get help with technical troubleshooting questions." Who knows, my questions might not even be that technical, but they seem it to me. Thanks in advance for any help.

you will probably find somebody on here that has the answer to any question jeep related you will have, whether it be electrical, suspension, drivetrain...you name it, and someone will have an answer, or at least a comment that should point you in the right direction.
Welcome! :wavey:

Hexxum 03-10-2010 12:49 PM

Welcome to the forum. You'd be amazed the knowledge you can already find tucked away in the message boards, or the answers for your questions. If it's a question that hasn't been asked, somebody else is sure to have it sooner or later, so ask away.

kijloy 03-10-2010 12:57 PM

Alright!!! I appreciate it. Here goes. I have the 4 cyl. 2.5 engine and before I try to modify anything i'm trying to get this engine working properly. I'm having trouble starting the engine. When it does start it runs without stalling. I've done the obvious as far as changing distributor cap, rotor, spark plugs. I haven't changed the wires because my local parts store didn't have them in stock but I checked for spark and I think I'm getting adequate spark to all four cylunders. SInce replacing spark plugs I've run the engine continouisly for about 4 days and I noticed the idle getting rougher and rougher. I pulled the spark plugs out and noticed that there was an unusual amount of build up on the first three cyl. but not much on the fourth. What could be causing the uneven build up? Is it related to my pproblems cranking the engine over? Any help or direction is greatly appreciated.

crtaylor 03-10-2010 03:09 PM

Have you done a compression check?
check the egr valve .

Garyk 03-10-2010 04:42 PM

Quote:

Originally Posted by kijloy (Post 567527)
Alright!!! I appreciate it. Here goes. I have the 4 cyl. 2.5 engine and before I try to modify anything i'm trying to get this engine working properly. I'm having trouble starting the engine. When it does start it runs without stalling. I've done the obvious as far as changing distributor cap, rotor, spark plugs. I haven't changed the wires because my local parts store didn't have them in stock but I checked for spark and I think I'm getting adequate spark to all four cylunders. SInce replacing spark plugs I've run the engine continouisly for about 4 days and I noticed the idle getting rougher and rougher. I pulled the spark plugs out and noticed that there was an unusual amount of build up on the first three cyl. but not much on the fourth. What could be causing the uneven build up? Is it related to my pproblems cranking the engine over? Any help or direction is greatly appreciated.

You got me confused, did you run the engine steady for 4 days? Idling? Or did you mean you drove it around? If you idled the engine for 4 days, the plugs are likely fouled...

kijloy 03-11-2010 08:37 AM

Thanks for the responses. I haven't done a compression check and I haven't checked the egr valve. I'll do that today and let you know how it went. Just to clarify I let the motor idle for about a half hour to an hour for four days. I didn't just run it non stop for four days. If there's any more advice I'd be greatly appreciative.

Garyk 03-11-2010 11:37 AM

does yours have fuel injection? I was reading somewhere in the Haynes manual that the fuel can bleed back and cause hard starting. Can't recall if its caused by the fuel regulator or at the pump.

WGLWRM 03-13-2010 09:43 PM

I have an 88 6 cylinder and mine is hard to start. Once it starts it runs like a raped ape. I have changed the card did a nutter bypass, cleaned out everything to include replacing everything, besides the motor itself. Had the compression checked everything was good to go.... So I have come to figure out.... Its just like me, hard to wake up first thing in the morning....

After it warms up, I can turn it off and let it sit for an hour or so and it will fire right up

kijloy 03-16-2010 05:18 PM

I have finally done the compression check. According to the Haynes manual I should have 155 to 180 psi. My engine is running at a consistent 150psi across all 4 cylinders. Is that not enough compression or is that ok? If its not how do I fix it? If it is ok then whats going on? Whats causing my spark plugs to get all gummed up? HELP!!!


All times are GMT -5. The time now is 02:02 AM.