Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Jeep cranks, no start....very confused...need help! (http://www.wranglerforum.com/f210/jeep-cranks-no-start-very-confused-need-help-46372.html)

kjdavis 03-11-2010 06:59 PM

Jeep cranks, no start....very confused...need help!
 
Okay, so this has me completely confused;

1997 TJ, 4.0L, 5 spd manual....

My current project was putting on front coilovers, redoing the front of the frame, new radiator, & bumper. I completed everything and had my bumper and antirock arms out at the powdercoater. Within that time, I've moved the Jeep into the driveway, drove it around the block, etc....getting it up to operating temp a few times. I got my bumper and antirock arms back from the powdercoater and put them on. Started the Jeep up fine, it ran fine for about then seconds before it started running rough, almost seeming like it was dropping cylinders, before eventually dying. Now it just cranks, does not fire.

Here's what I've checked/replaced;
-Compression on all cylinders is good.
-NEW cap, rotor, plugs
-NEW crank position sensor
-I do have spark at all wires
-Fuel pressure at the rail is 43 psi with key on, mid 30's when cranking
-fuel injectors DO get a pulse
-No codes
-when cranking, nothing sounds out of the ordinary

So with everything, it *should* fire up, I have spark, fuel, and air.

Any ideas?

Bouncy 03-11-2010 07:49 PM

I bought a new CPS from Autozone...Made in CHINA....bad from the box. Took me a year of foolin around till I swapped back in a used factory model and it worked perfectly.

JT Gibbs 03-11-2010 10:49 PM

Mines a 2.5L 4 cyl. it does the same things sometimes. I just let it crank for a while, till the starter grinds like its already started, sometimes then it will catch not always though. Other times I just floor it till it starts.

s3nt3nc3d 03-11-2010 10:53 PM

Quote:

Originally Posted by JT Gibbs (Post 569248)
Mines a 2.5L 4 cyl. it does the same things sometimes. I just let it crank for a while, till the starter grinds like its already started, sometimes then it will catch not always though. Other times I just floor it till it starts.

I'd avoid cranking it for extended periods of time or you may burn up your starter...they're not designed to crank for very long. I know on some of our equipment at work, the machine has a sticker right on it that says don't crank for any longer than 30 seconds. If it doesn't catch after 30 seconds worth of cranking, let the starter cool for 2 minutes before trying again. I'd imagine a Jeep start is a bit heavier duty than the starter on our big stump grinder...but I'm sure even it isn't designed to crank for long.

AzTJ 03-11-2010 10:58 PM

Tried putting some carb cleaner in the throttle? Will it start then?

I was helping a friend diagnose a TPS issue on his XJ and it would do this same thing. Make sure connections are tight and free of debris and moisture. Try and start it. If no fire, then spray some brake/carb cleaner in there and see if it will.

kjdavis 03-11-2010 11:16 PM

I did dump a bit of gas down the intake and it did fire...then quickly dies when that burns off.


Hmmm...guess I need to check the TPS

AzTJ 03-11-2010 11:20 PM

Maybe not TPS then. It's electrical somewhere though.

kjdavis 03-11-2010 11:40 PM

Im just wondering if it is the ECU. The ECU controls the timing and injectors, and since Im getting fuel, and spark...it seems like they arent in sync.

Indy 03-12-2010 12:26 AM

Try resetting the ECU ... see if that helps .. you never know :)

kjdavis 03-12-2010 12:59 AM

Done that...several times.

:D

rrich 03-12-2010 09:12 AM

You won't believe me on the other board, so try asking on here what the fuel pressure should be at the rail when running or cranking, not just static.
(Been there, done that several times.)

Or - try replacing the ECU like you seem to want to if you think it'll raise fuel pressure.

In any event, let us know.

chop110 04-19-2010 05:57 PM

Kjdavis, whatever became of this?

kjdavis 04-19-2010 06:02 PM

Well, after checking EVERYTHING else again.....

I put some fuel down the intake and was able to start it, fired right up. I had a fuel pressure gauge hooked up to the fuel rail and was able to burp the system and release some fuel into the intake through the release tube of the pressure gauge, kept it running. It was only then that I noticed a TON of water passing through the clear tube of the gauge.

I emptied the tank...again....and put some fresh fuel in with injector cleaner. Its taken burning through a full tank to get it to run smooth.

So...the problem ended up being a ton of water. Not sure how it got there...only theory I have is that my fuel cell was low, and being aluminum it "sweated". But it would have to sweat a ton to get that much water.

Jerry Bransford 04-19-2010 06:25 PM

With that much water in the tank, I would have to guess someone dumped it into your tank. It wouldn't sweat that much water into the tank.

kjdavis 04-19-2010 06:31 PM

That's the thing though, the thing is garaged....just sees trail duty.

chop110 04-19-2010 09:31 PM

Interesting. Mine started doing that not too long ago. I would try to start it and it would crank but not fire up. After a couple of hours, it would start again. I had the fuel pump replaced last week but then it did it again today. Last I checked, it runs now.

Funny, before you mentioned the water thing, I have been hearing things about our local gas stations (Houston, very humid) had water in the gas wells. Anyway, I am going to try putting in some Methyl alcohol in the tank to see if it helps.

chop110 04-19-2010 09:49 PM

Thanks for responding btw and I am glad to hear your Jeep issue got resolved. :)


All times are GMT -5. The time now is 10:05 AM.