Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   New to the forum, have an engine question (http://www.wranglerforum.com/f210/new-to-the-forum-have-an-engine-question-46550.html)

TJnVegas 03-13-2010 09:20 PM

New to the forum, have an engine question
 
2 Attachment(s)
Hey all!
I just bought a used 97 wrangler and lovin' it! Just started with an oil, air filter and spark plug change, and found a few concerns. First, it seems like there is excessive oil build up on the front of the motor. Not sure but maybe it needs a new valve or head gasket. Second, when i pulled the spark plugs the number 1 and a little of 2 plugs seemed to have a lot of build up on it (burned, or caked on, but not rich or flooded look). So there's my problem, any help would be great!

pokey 03-13-2010 09:30 PM

If the jeep runs good, the plugs may just have been overdue for a change. They don't look too bad. The oil could be the valve cover gasket. If its not dripping on the ground I wouldn't worry about it.

gmiller0737 03-14-2010 07:47 AM

Welcome to the forum, As far as the spark plugs it looks like a little ash deposits pretty normal for a vehicle with higher milage I would not worry about it,as far as the oil leak issue clean it up then re check it possibly the valve cover gasket,If you need to replace the Valve Cover Gasket try to get Fel Pro's Perma Dry Gasket they are one of the best gaskets out there.

TJnVegas 03-14-2010 12:15 PM

Thanks to both!
 
Thanks for the quick response, i think ill take the advise....maybe change the valve cover gasket and let it ride! Thanks again, its good to have outside thoughts. have a good one!


All times are GMT -5. The time now is 10:13 PM.