Jeep Wrangler Forum

Jeep Wrangler Forum (
-   YJ General Discussion Forum (
-   -   Signal and brake lights just quit working (

fullboar01 03-14-2010 08:35 PM

Signal and brake lights just quit working
Hi Just replaced the front seats in my yj, and for some reason the signal and brake light just quit working!!!! WTH? checked all the obvious fuses, bulbs etc still nothing. just maybe someone has a idea!

NAVYCHIEF 03-14-2010 09:27 PM

both of them? one of them?

derekshep 03-14-2010 09:37 PM

only thing i can think of is maybe you hit the wires going to them somehow? othere than thats i'm lost

Jaydogg25 03-14-2010 10:06 PM

what i like to do to make sure is use a test light and test every fuse, in every location. i have seen fuses look good but are not. make sure to have ign on to test fuses easier.

from that point if they all look good i would go to switch and test wires there. (break switch & parking light switch), now if it's turn signals then check relays for that.

cant say i have seen that issue from replacing a seat..though i have had to change my break switch several times on my 95.

brent in az 03-14-2010 10:39 PM

After reading this twice I have to say as weird as it sounds that seat swap-out and absences of signals/taillights immediately after is prolly not a coincidence.

I've swapped seats out before. I've never noticed any auxiallry grounding wires or any electrical wires whatsoever in that part of the undercarriage. You were under the jeep, right?

89YJislander 03-14-2010 11:03 PM

When i had some eletric problems i just replaced the ground wire, just a sugestain

fullboar01 03-14-2010 11:58 PM

thanks i will try its all just a bit weird

All times are GMT -5. The time now is 09:39 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.