Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Firestarter for a 98 Wrangler? (http://www.wranglerforum.com/f210/firestarter-for-a-98-wrangler-47668.html)

TxJeepHunter 03-28-2010 09:29 PM

Firestarter for a 98 Wrangler?
 
Sorry to post a thread being a rookie and all, but I've spent the past 2 days crawling all over my jeep and the past two hours searching the forum and couldn't find the magic thread...any help is greatly appreciated.

I've got a 98 Wrangler Sport 4.0 (manual) with two problems that I can't figure out. 1st, the guages magically quit working at various times (RPM, Speedo, Battery, etc..). I read once that you can hit the dash and it will fix it. Well it did, the first few times. Now it just feels like the old b/w TV we had when I was a kid. You can bang on it all day and nothing happens. :crash:

Second, the more troubling problem is that it won't start. I'm not getting any fire. I've pulled spark plugs to check wires and I'm getting no fire from the distributor. I replaced the coil and then decided to check fire from coil to distributor...nothing. I even tried to check for voltage coming into the front side of the coil but couldn't get a reading on the tester. I've checked the 20Amp fuse in the Power Distribution Center and it looks fine also. Somehow, I'm not getting fire from the battery/ignition to the coil. Any suggestions are greatly appreciated. Mr Haynes and his manual leave a lot to the imagination in their wiring diagrams. :banghead:

TxJeepHunter 03-29-2010 08:22 PM

Okay, after further research, I heard that it might be the Crankshaft Sensor, so I replaced that and still no fire.

Beuler...Beuler...anyone....anyone...???

pokey 03-29-2010 08:37 PM

It sounds to me like your best case scenario. I think you need a new battery. And get rid of the Haynes and pick up a technical service manual off ebay for a '98. Well worth it.

TxJeepHunter 03-29-2010 09:08 PM

Sorry, I forgot to mention that. The first thing I did was change the battery. It was completely dead. Also, I tried swapping relays around to see if it might be a relay. No dice there either. Thanks for the tip on the technical service manual, Pokey. I'll see what I can find.

TxJeepHunter 03-29-2010 09:29 PM

To clarify...The starter is turning over plenty fast enough to start. It acts like you're out of gas...it just keeps turning over. I have fuel, I'm just not getting any fire to the coil / distributor / plugs.

birdhunter 03-29-2010 09:52 PM

Does a TJ have a ICM
like the YJ

TxJeepHunter 03-29-2010 09:58 PM

Based on the Haynes Manual I'd say no. It says Ignition Control Module is only on 1990 and earlier 4-cylinder models.

pokey 03-29-2010 10:02 PM

Hmm, my second guess would be the coil but you said you replaced it. It sounds like you checked everything thoroughly, double check all your connections (wires). The only thing I can think of is the replacement coil was bad. I'm sure someone with more knowledge will chime in. By the way, no need to apologize in your first post. You did things the right way, you spent 2 hours doing a search first! Good luck.

TxJeepHunter 03-29-2010 10:10 PM

10-4. Thanks for effort Pok. My cousin says it might be in the ignition itself. It seems like ignition would be fine since the damned thing is turning over, but I'm grasping for straws now. I guess I'll try buying a new ignition switch tomorrow.

pokey 03-29-2010 10:23 PM

That's probably not a bad guess. I know they do go bad and cause some strange electrical issues when they do. They are about $75.00 at the dealer. I had to change mine.

TxJeepHunter 03-29-2010 10:28 PM

Well, I guess it could be worse. Are they hard to install? I wondered if you have to take apart the steering column or not.

pokey 03-29-2010 10:53 PM

I had a mechanic relative do it and I wasn't there but I don't think it was that big a deal. I don't think you have to take apart the column.

Jerry Bransford 03-29-2010 11:40 PM

Here's a writeup on fixing the gauges... TJ Jeep Problem with Instrument Guages.. I did that to my '97 like 11-12 years ago and it has been solid ever since.

On the lack of spark, that is often caused by a bad crankshaft position sensor which generates the engine's master timing signal. When there is no CPS signal, the engine computer won't turn the ignition on or pump fuel.

TxJeepHunter 03-30-2010 08:32 AM

Jerry. Thank you very much. What a great writeup. I'll do it tonight. I replaced the CPS last night and still no fire. By the way, nice website.

Thanks Pok. I checked the manual and it looks like a pretty simple process to remove the ignition switch. I'm going to try and find one today and get er done along with the guage fix.

TxJeepHunter 04-03-2010 02:27 PM

Alright, I've replaced the Crankshaft Position Sensor, the Cam Pos sensor, the battery, and the coil. I've checked all the fuses and swapped out relays in the pdc. I still have no fire coming out of the coil.

One thing I noticed this morning was the battery is dead. This thing has set for months at a time and the battery has always been fine. I've checked to make sure all lights / stereo are turned off, but I'm not sure what is now pulling on the battery that wasn't before. Does anyone know / think I may have a ground short or a wire short somewhere that's pulling down the battery and might be causing the lack of fire issue?

I've done everything my little pea brain can think of and any guidance / ideas area greatly appreciated?!?

TxJeepHunter 04-03-2010 05:15 PM

:banghead: After two trips to the store (the torx bolt is tamper-proof and requires a special tool), I successfully replaced the ignition switch. This did not fix the problem. I'm not sure what other electrical parts will impact fire. Is the computer the next obvious step?

TxJeepHunter 04-04-2010 02:53 PM

Alright then, I guess I'll try to find a remanufactured computer. Noticed a company on ebay out of Fla that does it and sells them for about half price. Anyone had any experience with remanufactured computers?

pokey 04-04-2010 03:49 PM

Man TxJeep, I feel for ya. I wish I could offer something. As far as the battery goes, It will drain down if it sits for months if the cables are connected. Even the clock on the radio will pull some current. Im assuming you charged/ changed the dead battery? Before you shell out $$$ for a computer I would double check everything.

You said the 20 amp fuse in the PDC looked good. I read where you can't always tell if a fuse is good by looking at, it may look o.k. but be blown. And double check the new coil, make sure the new one is good. It sounds like you are checking everything thoroughly. Now you got me curious as to what the heck is going on. At least you have a lot of new parts in the jeep. Good luck man, and let us know when you get her running .

Levinoss 04-04-2010 04:49 PM

TX

There was a recall for the 98 instrument cluster. Run your vin on the jeep website and see if it was ever fixed on your jeep or not. If it's on there still they will send you the new female connection and its a simple swap out. When I bought mine the previous owner gave me the one they sent to him. He was just too lazy to change it him self so me and my brother fixed it one day. Never had a problem again...

TxJeepHunter 04-05-2010 09:35 AM

Pok...Yep, the first thing I did was replace the battery and it was dead in a week. I replaced the 20 amp fuse (I was thinking the same thing) but that didn't help. The reman computer is on the way. Thanks for the suggestions though. I'll keep post after computer install.

Lev...I appreciate the tip on that instrument cluster as well. Jerry B sent me a great tip on how he fixed a problem with his cluster but it didn't work on mine, so I'll definitely try that. I assume by "Jeep Website" you mean an official Chrysler / Jeep website? I'll nose around to see what I can find.

TxJeepHunter 04-05-2010 10:21 AM

Levinoss, I checked the jeep website and no open recalls exist for my Jeep. Can you tell me what it was they sent? By the sound of it, they sent you the female connectors that the instrument cluster attaches to??? or was it the cluster itself?

Levinoss 04-05-2010 12:16 PM

Quote:

Originally Posted by TxJeepHunter (Post 590408)
Levinoss, I checked the jeep website and no open recalls exist for my Jeep. Can you tell me what it was they sent? By the sound of it, they sent you the female connectors that the instrument cluster attaches to??? or was it the cluster itself?

They sent a female connector that the cluster plugs into. Might just try the quick fix jerry posted.

Jerry Bransford 04-05-2010 12:39 PM

Quote:

Originally Posted by Levinoss (Post 590465)
Might just try the quick fix jerry posted.

He might as well since that fix is quick to perform, totally effective, and and totally free.

TxJeepHunter 04-05-2010 01:58 PM

I already tried it. I also applied dielectric grease to the connectors but it didn't work. Maybe I didn't twist the prongs enough. However, there was a noticeable twist in everyone. The fix makes perfect sense. It just wasn't successful on my hunk of camo. I'll try mas twist and see what happens.

TxJeepHunter 04-16-2010 09:04 AM

:D SUCCESS HAS BEEN ACHIEVED!!! I wanted to thank you all for the tips and ideas on the problem with my Jeep and to share what happened in hopes this might help others down the road.

Quick recap: My Wrangler sat for about 6 months. When I tried to start it battery was completely dead (which has never happened before) and I've let it sit that long. I replaced the battery but had no fire and most of my guages weren't working. Jerry shared a great article on how to ensure connection to the guages. I did that and added dielectric grease but it did not fix the problem with the guages (at that moment). I had no fire from the coil to the distributor, so I replaced the coil. No help. I replaced the Crank Pos sensor. No help. I replaced the Cam pos sensor (located inside the distributor). No help. I replaced the ignition sensor. No help. I replaced all the fuses and swapped around all the relays. No help. In short, I tried all the cheap fixes first. Finally, based on the wiring diagrams, we took a shot at the computer. The second I replaced it, the guages started working and it fired right up. I found a company out of Florida that sells remanufactured computers for $175.00 or they'll overhaul yours for $125. It's called Auto Computer Exchange if anyone needs one. Problem solved.

I'm not sure if I should have snapped to the fact that the guages weren't working even after confirming good connection. But, maybe this will help someone down the road. My next step was going to be pulling apart wires and checking for bare wires.

Thanks again for all the ideas and information! Hope this helps others!:punk:

Glenn54 04-16-2010 12:15 PM

Good job. Thanks for lettings us know.

Jerry Bransford 04-16-2010 12:34 PM

Very cool, not many computers go bad so congrats on figuring that out on your own! :punk:

Levinoss 04-17-2010 09:22 AM

Good to see you got it working.


All times are GMT -5. The time now is 07:22 AM.