Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   CEL help (http://www.wranglerforum.com/f210/cel-help-479385.html)

TJ4X4 01-12-2014 02:54 PM

CEL help
 
Ok....I know there are a lot of CEL threads here, but I have used up all my knowledge on this one. Here is what I have.

2005 TJ, 4.0L, Auto, with 90,000 miles

I was driving a week ago and my CEL came on, stopped by auto zone and the code was P2098 "Downstream fuel trim system 2 lean." So I take it by my mechanic and he says the ECM needs to be updated so he does it and the CEL goes away. 5 days and 200 miles later the CEL comes back on.

New code is now P0153 "O2 sensor circuit slow response bank 2, sensor 1."
I call the mechanic and he tells me to bring it back in tomorrow so he can see the code. Has anyone had this happen where different codes pop up? If so any ideas on how to fix this issue. It seems to me that the O2 sensors might be bad or on the way out.

Thanks

bschurr 01-12-2014 04:10 PM

I just replaced my 2 upstream O2 sensors - less than $80 in parts and 10 minutes of my time. No more P0153 for me.

There is a bunch of debate about when these sensors should be replaced and I replaced both upstream units instead of just the 1 that was related to the specific code that you mention. I shouldn't have to worry about them for the next 100K miles.

BTW - how is your gas mileage? If it is poor and/or declining - replacement of the 2 upstream sensors should provide some improvement.

TJ4X4 01-12-2014 05:27 PM

Thanks for the info. I have the tools for it, just need to go and get the sensors. I will try that tomorrow.

bschurr 01-12-2014 07:38 PM

Quote:

Originally Posted by TJ4X4 (Post 7390265)
Thanks for the info. I have the tools for it, just need to go and get the sensors. I will try that tomorrow.

DO NOT buy Bosch sensors - get the NTK (OEM replacement) or Denso. There is a special Oxygen Sensor removal socket but it isn't really necessary - an open end 22mm or adjustable should do the trick.

Roblaza 01-12-2014 07:56 PM

I'm sorry, but I've never heard of "the ecm needing to be updated"... that seems odd to me. if it's throwing a code its because the computer is seeing incorrect data from a sensor. an ecm in a jeep is not like a iphone where they keep doing changes and it requires updates...

Majnoon 01-12-2014 08:04 PM

Quote:

Originally Posted by Roblaza (Post 7394073)
I'm sorry, but I've never heard of "the ecm needing to be updated"... that seems odd to me. if it's throwing a code its because the computer is seeing incorrect data from a sensor. an ecm in a jeep is not like a iphone where they keep doing changes and it requires updates...

I vaguely remember a recall on 97's I think they did an update. I agree with Roblaza, he's full of it. Sounds like he cleared the code with a scan tool. For his "update" edit and although it was 2 different codes they are coming from the exhaust.

TJ4X4 01-13-2014 03:41 PM

Ok so I drop it off again at the mechanic (a national chain) and he now tells me the O2 sensors are good and that I need an ECM which costs $1000. I said put my Jeep back together and I'm on my way to pick it up. I get there ticked off, pick it up and drive it away. Just like going to a doctor, I go to the Jeep dealer in my area and ask them to run a diagnostic on it for a second opinion. They come back about an hour ago with the same response. "You need a new ECM."

Has anyone had an issue like this or even heard of it?

Blackhawk36 01-13-2014 03:49 PM

90k miles is about right for an O2 sensor to go bad. Why not just replace the obvious?

bschurr 01-13-2014 04:09 PM

Quote:

Originally Posted by TJ4X4 (Post 7413057)
Ok so I drop it off again at the mechanic (a national chain) and he now tells me the O2 sensors are good and that I need an ECM which costs $1000. I said put my Jeep back together and I'm on my way to pick it up. I get there ticked off, pick it up and drive it away. Just like going to a doctor, I go to the Jeep dealer in my area and ask them to run a diagnostic on it for a second opinion. They come back about an hour ago with the same response. "You need a new ECM."

Has anyone had an issue like this or even heard of it?

New ECM? Perhaps but, I would certainly question it as well!

What codes are you seeing?
What symptoms?

TJ4X4 01-13-2014 04:58 PM

As far as symptoms, there are none, with the exception of the CEL coming on.
Codes I have so far:

1st time - P2098 - downstream fuel trim 2 lean

2nd time - P0153 - O2 sensor circuit slow response bank 2, sensor 1.

3rd time - P0152 - O2 sensor circuit high voltage, bank 2, sensor 1.
P0057 - HO2S heater control circuit low, bank 2, sensor 2.

I have to agree with Blackhawk that the focus is on the O2 sensors, especially in bank 2. I have gotten all these codes within the last week with no other trouble since I have had the Jeep. I will probably order the NTK sensors and install them before I do anything else especially since I can afford sensors easier than a new "PCM" as the dealer corrected me on it. Let me know what you think.

bschurr 01-13-2014 07:41 PM

Quote:

Originally Posted by TJ4X4 (Post 7414881)
As far as symptoms, there are none, with the exception of the CEL coming on.
Codes I have so far:

1st time - P2098 - downstream fuel trim 2 lean

2nd time - P0153 - O2 sensor circuit slow response bank 2, sensor 1.

3rd time - P0152 - O2 sensor circuit high voltage, bank 2, sensor 1.
P0057 - HO2S heater control circuit low, bank 2, sensor 2.

I have to agree with Blackhawk that the focus is on the O2 sensors, especially in bank 2. I have gotten all these codes within the last week with no other trouble since I have had the Jeep. I will probably order the NTK sensors and install them before I do anything else especially since I can afford sensors easier than a new "PCM" as the dealer corrected me on it. Let me know what you think.

I think you are on the right track! Nothing pointing to PCM replacement but all indications are pointing to O2 sensor issues.

What kind of mileage are you currently getting and how do you drive? Have you seen a drop in MPG since the CEL came on?

RUBI 4 MY MRS 01-14-2014 02:08 AM

The ‘05s have a TSB for 2096 & 2098 codes which requires a reflash of the PCM. However an exhaust leak can cause those codes too. I think the 2098 is bank 2 & I see that all the other codes are bank 2 so there may be some connection, so check for an exhaust leak on the back (bank 2) section of the manifold/pipe. Here a 2 links that may help.


Code 2096

How to fix code 2096

Roblaza 01-14-2014 07:48 PM

sounds like you need an o2 to me. as ^ said, check for exhaust leaks PRE downstream o2, as well as check for vac leaks. they can throw rich or lean codes aswell.


All times are GMT -5. The time now is 10:12 AM.