Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   CEL Flashing - w/ new crankshaft sensor (http://www.wranglerforum.com/f282/cel-flashing-w-new-crankshaft-sensor-49800.html)

s-seely 04-28-2010 11:27 AM

CEL Flashing - w/ new crankshaft sensor
 
My 2001 Jeep Wrangler, 6-cyl., Sport model broke down two weeks ago without warning. Mechanic replaced the crankshaft position sensor. Ran like new afterwards. No previous problems with it - no blinking engine lights even after break down. Immediately after driving off mechanics lot the engine light started flashing (only after to 40-mph). Happened intermittently for a day, lasting about 10 seconds per batch of flashing episodes. Took back in and they replaced spark plugs + carbon clean-out. $300 later same problem. Blinking light intermittently. Blinking occassionally then turns to solid engine light that stays on and is on when car is turned back on. Mechanic replaced the "new" crankshaft sensor with another one, but both sensors were "after-market". Could that be the problem? Jeep runs completely fine! Even before the break-down there was no indication of trouble. Codes reading from the diagnostic since the blinking started suggest misfire on 4,5,6. Another reading on a different diagnostic machine showed irregular wave forms. Still, nothing running differently. Help!! Am I causing damage to cat.con. by driving with blinking light???

AzTJ 04-28-2010 01:55 PM

Check the codes yourself and see what they say. A blinking CEL usually is something important.

Jeep TJ Diagnostic Codes

s-seely 04-28-2010 03:12 PM

The odometer read P0300 & P306. The engine light did not blink so I don't know what the code(s) is that is related to the link you provided.

mrcarcrazy 04-28-2010 03:17 PM

300 is random mulitple misfire, 306 is cyl 6 misfire.

I have no clue what the problem is.

AzTJ 04-28-2010 03:46 PM

Quote:

Originally Posted by s-seely (Post 611110)
The odometer read P0300 & P306. The engine light did not blink so I don't know what the code(s) is that is related to the link you provided.

Sorry that was the wrong link. :redface:

Like stated, cyl 6 miss-fire. Could be fuel related and not electrical.

MTZjeep 10-04-2011 10:44 PM

Did you ever resolve this miss-fire problem? Just got a 2002 Wrangler Sport and having same problem. Any information would be helpful.


All times are GMT -5. The time now is 07:25 PM.