Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Weird electrical issue (http://www.wranglerforum.com/f210/weird-electrical-issue-5040.html)

Geeps 01-05-2007 11:48 AM

Weird electrical issue
 
For the last couple of months I have been noticing my battery (an Optima yellow top) has been slowly losing power. I just thought it was because I hadn't been driving the Jeep that often. The other day I got into it and noticed the interior lights weren't working. They would work off of the light switch, but not the door switch. I checked the fuse, no problems. When I re-inserted the fuse, it arched but it didn't blow. I replaced the fuse, and now the battery is back to normal.

Can someone explain how that fuse and circuit, that is suppose to be on only when the doors are open, could have been draining the battery's power??

skeeter 01-05-2007 11:52 AM

The switch got some moisture in it?

Odhinn 01-05-2007 12:23 PM

I would think you should have power in the line from the fuse to the door switch. The switch is the on/off point for the electricity.

AzTJ 01-05-2007 06:49 PM

Quote:

Originally Posted by Odhinn (Post 43146)
I would think you should have power in the line from the fuse to the door switch. The switch is the on/off point for the electricity.

Might have a sticky switch where a bit of current gets through and slowly drains it, especially if it sits for a few days.

compshooter 01-08-2007 01:21 PM

For about 26 bucks Ace Alternator will troubleshoot your electricial system and let you know where the problem is. Obviously, more money to fix it, but having them locate it and then you fix it works. Had to do that on my Toyota and was worth every penny having them find the location of the short.

Geeps 01-08-2007 01:49 PM

I'm chalking this one up to the fuse. I haven't had any problems since.


All times are GMT -5. The time now is 09:36 AM.