Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   '95 Odometer Stopped Working (http://www.wranglerforum.com/f218/95-odometer-stopped-working-50588.html)

drum03 05-11-2010 08:28 AM

'95 Odometer Stopped Working
 
The odometer stopped working on my '95 YJ. All the other gages still work (including the spedo). Any thoughts as to what could have caused this issue?

The only explanation I can come up with stems from media blasting the drivers side floor board last fall. After blasting the floor there was media dropping from under the dash for about a month. I finally took the dash apart, removed the gage cluster and blew out the remaining media with an air hose. The odometer stopped working about two months after this. Could the media have worked its way into the cluster and bound up the odometer gears?

Any input will be greatly appreciated!

Robby

drum03 05-14-2010 07:09 AM

Has anyone else had this problem? I plan on working on my Jeep tomorrow and would like a few ideas that I can troubleshoot.

The only other possible cause that I found while searching was a bad connection between the gage cluster and wiring harness.

Kohrs93 05-14-2010 10:21 PM

A fuse? I know my friend had the same problem with his gas gage and a 10 cent fuse fixed the problem.

drum03 05-19-2010 07:18 AM

I checked the fuse for the gage cluster last night. It was still in tact. Is there an individual fuse for each gage that I'm missing?


All times are GMT -5. The time now is 09:47 AM.