Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Jonny Joint rebuild?? (http://www.wranglerforum.com/f210/jonny-joint-rebuild-50901.html)

not4hire 05-15-2010 08:49 PM

Jonny Joint rebuild??
 
I have the JKS front trac bar on my TJ and it has lots of play from side to side.

My question is should I replace just the bushings or everything?

I see they sell all the parts by them selfs...The trac bar only has 10k on the bushings...I don't think they should of failed so soon...

Thanks for the help..

MR.CLIFFORD 05-15-2010 08:55 PM

Which end has the play? The nice thing about the JJ is that it is rebuildable. So you don't have to replace the whole track bar. It's the reason I run them in my control arms. Just replace the bushings instead of the whole thing.

There are plenty of reasons why the bushings can fail. If your front end isn't assembled correctly you will have advanced wear on a normal wear and tear part. 10k on a normal operating rig shouldn't wear out those bushings.

stevens243 05-15-2010 09:22 PM

Yeah, 10k isn't a lot unless it's all on double diamond rock runs.

When was the last time it got greased? I'm not sure I'd buy parts until I pulled it apart and saw if it was damaged. If it is, I think I'd start looking for cause first.

not4hire 05-15-2010 10:46 PM

I did take it a part today. I found no worn parts.
This is for the front trac bar. The joint mounts at the frame.

I grease the suspension every 3000miles at every oil change.
All the mounting bolts and hardware is tight and in good shape.
I'm at a lose on why this is happening.

MR.CLIFFORD 05-15-2010 10:48 PM

Quote:

Originally Posted by not4hire (Post 625507)
I did take it a part today. I found no worn parts.
This is for the front trac bar. The joint mounts at the frame.

I grease the suspension every 3000miles at every oil change.
All the mounting bolts and hardware is tight and in good shape.
I'm at a lose on why this is happening.

What kind of lube are you using?

not4hire 05-15-2010 10:52 PM

I'm using regular grease you get in a tube for suspension.

MR.CLIFFORD 05-15-2010 10:54 PM

It should be moly lube. You should only use moly lube in a Johnny Joint. Anything else will eat the races around the JJ.

not4hire 05-15-2010 10:58 PM

I will go look and see if it is moly lube...

Thanks for the help

not4hire 05-15-2010 11:04 PM

Ok it is moly lube.

Were else would be a good place to look for problems?

distortedtj 05-15-2010 11:13 PM

Question...the play at the joint at the frame....is it in the joint ...or the bolt...mite try making sure the bolt is snug and the hole is not buggered up.

stevens243 05-15-2010 11:18 PM

Man, I hate all the technospeak on this forum..

Buggered up is just so hard to follow. :D

I just re-read the OP. Side to side movement? Is the tracbar end connected to a stock link? I think that might be normal if so. Besides the side to side movement, are you getting any other indications of a problem?

distortedtj 05-15-2010 11:21 PM

I'll try to dumb it up more for you Larry.:flipoff:

stevens243 05-15-2010 11:24 PM

Can't. take. anymore. up.

Can you dumb it down instead? :D

distortedtj 05-15-2010 11:30 PM

Sure...make sure the mounting hole is not ovaled or wallered out.

"""the JKS tracbar requires you to drill out the factory frame hole to fit the larger bolt.""

Sometimes the hole is not drilled straight or the bolt comes loose and can oval the bolt hole. In essence jacking the hole up and leaving play in the tracbar. not good.

Got it now smarty pants. :p

stevens243 05-15-2010 11:36 PM

Oh. Ok.

Got it.

Well, IF his hole isn't wallered out (jeez) and he is only getting side to side movement AND the frame tie is stock I think that the easiest thing to do is to pull the nut off the bolt, if necessary, put the bolt in from the other side so that you have access to the link point without the bolt in the way but with the tracbar still in place, remove the tire and with a BIG damn hammer, smack the link until the joint is nice and tight (ooohhh) within the link and bolt it back together.

But, maybe your hole is just buggered up...

distortedtj 05-15-2010 11:38 PM

:rofl:

not4hire 05-16-2010 02:25 AM

LOL... The bolt is nice and tight...Not buggered up...

The side to side movement is only in the trac bar itself, I have the stock mount on the frame.

The best way to describe it is bolt and inside joint stay put and don't move at all. The trac bar moves around the joint like it has worn bushing, but bushings look great. So maybe this is normal?


All times are GMT -5. The time now is 03:39 AM.