Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Electrical Nightmare! (http://www.wranglerforum.com/f210/electrical-nightmare-51290.html)

Lowrollin12 05-21-2010 08:57 AM

Electrical Nightmare!
 
So 1st I thought i was having issues with the ignition switch when I would have the air bag light come on, No wipers, no radio and no heat. Then it would 1/2 resolve itself and i just wouldnt have wipers and couldnt use the fan on high....

Now the jeep wont start with out a jump and the voltage is around 19 volts on the dash....

I think this could all be from the ignition switch but what do you think?

meyers 05-21-2010 01:37 PM

The voltage is 19volts at the dash? How are you checking this voltage, the battery is only 12 volts. You may get 14 - 14.5 when charging. But 19 is way out of spec.

Lowrollin12 05-21-2010 02:44 PM

No the voltage on the guage cluster is reading that... Im not saying that is what it really is but something is going on...

pokey 05-21-2010 03:39 PM

Yes. Bad ignition switch. Classic symptoms. Mine did the same thing.

Lowrollin12 05-22-2010 05:56 AM

Quote:

Originally Posted by pokey (Post 630878)
Yes. Bad ignition switch. Classic symptoms. Mine did the same thing.

thanks for the help!

deathphoenix99 05-22-2010 09:39 AM

As for the dash reading 19 volts, dash gauges are known to be horrbly inacurate, I suggest you check the voltage at the battery when the jeep is running, if it is 19 volts, TURN IT OFF IMMEDIATLEY. That high of a voltage will do damage to your electronics. If it is that high, then the voltage regulator on the alternator is bad. I believe it's built into the alternator and is not replaceable, meaning you will have to replace the alternator.


All times are GMT -5. The time now is 06:39 AM.