Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   My 4 wheel drive is not engaging! (http://www.wranglerforum.com/f218/my-4-wheel-drive-is-not-engaging-51626.html)

zacharytyoung 05-26-2010 09:12 AM

My 4 wheel drive is not engaging!
 
For some reason on my 1989 yj my 4 wheel drive is not engaging. When i put it in low 4 wheel drive, low gears kick in but not the 4 wheel drive. A freind of mine said that it may be a fluid that has leaked out of it and that maybe the reason. Im not sure but when i first bought it the 4 wheel drive did work and there was a little leak of something that did not have a smell, i know a substance was leaking from the jeep but could never figure out what it was. Finaly the leak stopped, and i went one day to engage my 4 wheel drive and it didnt work. Could the leak be what my friend was talking about or is there another reason?

whitebuffalo 05-26-2010 09:25 AM

no. it is most likely (almost certainly) the CAD on the front axle. it is a vacuum actuator to lock the passenger side shaft in. verify the vacuum lines are good to it (they come from the t case). if they are good, remove the CAD and check it out. you can replace it with a cable actuated one or repair it. usually, it is the diaphragm that goes bad, but on occasion the fork will crack.

easiest way to check it out is remove the CAD and let it hang. then, with the jeep running, shift back and forth from 4wd to 2wd and see if the fork is moving back and forth.

flatline 05-26-2010 09:41 AM

how did you know it wasn't working? are you going by the light on the dash?

zacharytyoung 05-26-2010 10:32 AM

No im not going by the light on the dash, the dash light sensers are all jacked up im in the prcess of rewiring, something im acctually good at, but the way i can tell it was working in the irst places is i made sharp turns on concrete and it made the sound of the front tires grabbing, now it wont make that sounds of the tires grabbing. o and i got stuck in a pit and try to engage the 4wheel drive an the front tires wouldnt work at all.

flatline 05-26-2010 11:30 AM

just asking, not trying to be a smart ass. the CAD is normally the problem with YJ's. easy thing to check first is vacuum to the cad, then cad. if all that works,check that you haven't broke an axle. then is the transfer case working, only thing that drives the front drive line is a chain.

toshpate 05-26-2010 11:45 AM

my vacuum lines actually come out..make sure they are plugged in, mine didnt work either and a line had come loose, pluggedit in an abra cadabra it worked.. hate the vacuum stuff grrr

jepptone 12-20-2013 09:28 PM

does some one have a good diagram of the true vacuum lines and exactly where they belong. My 89 jeep yj differential locks in but won't engage front wheels. no dash light either lighting up.

M48a3 02-09-2014 09:24 PM

I agree, does anyone have a good diagram of the vacuum line setup / connections from the T.C. to the front diff?

90DesertTanYJ 02-10-2014 04:54 AM

No diagram but there is one in the FSM. In a nut shell, vacuum comes from the engine, usually on the same line as the distributor. This goes to a switch on the transfer case. When you shift to 4wd, the switch sends vac to the CAD which couples your axles together, The CAD sends vac to the 4wd switch on the firewall which in turn closes the ground to the 4wd light. When you shift out, the vac is relieved by anothe vac line that goes also to the firewall. Its one that has a cane bend with nothing else.

Any of the switches, vac lines, the CAD motor could be bad. You could trace the vac lines with a vac gauge, checking all the functions.

Honestly its probly better to lock your CAD fork over or get a Cherokee/TJ one piece axle and TC switch. and be done with the CAD altogether. Check the stickies at the top for more info on how to do this easy mod.

vmaxaholic 02-11-2014 08:30 PM

I could write several paragraphs on how AWESOME the posi lock upgrade is. I've already written several in the last few days for other YJ owners with the same and/or similar problems. My issue was very similar. 4wd would sometimes engage, sometimes not...even if the light came on, sometimes still no 4wd. I installed the posi lock upgrade this past weekend and when I was finished, I wanted to kick my own ass for waiting as long as I did to do this. Now there is NO question about 4wd. I engage the t case, pull the cable and BAM!!! Instant, undeniable 4 wheel drive. Quadratech has them for $159. I got mine on ebay for $98 plus $12 shipping. Another guy on this forum said he got his shipped for $87 from Amazon. F*#k the CAD and the damn vacuum lines!!!! Do yourself a favor, and get the upgrade. This, of course, is assuming that your axle is good and the t case & linkage are all functioning properly. :)

DigitalDisciple 02-16-2014 05:44 AM

There is a way to delete the need for those vacuum lines with a couple of washers in the actuator. Look into that and delete those vacuum lines

DigitalDisciple 02-16-2014 05:46 AM

Home made POSI LOCK write up - JeepForum.com

How to: Vacuum Disco Elimination, Axle Tube Sleeve Fix, ubolt eliminator - 56K beware - JeepForum.com

These might be of help


All times are GMT -5. The time now is 04:05 PM.