Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Problem with turn signals and lights (http://www.wranglerforum.com/f218/problem-with-turn-signals-and-lights-52687.html)

Mcdougan 06-10-2010 02:18 PM

Problem with turn signals and lights
 
Hello, this is my first post in this forum I looked around to make sure this wasn't posted before and cant seem to find anything about it so here is my problem any thoughts or ideas would be great

About a week ago I accidentally ran over the cord that attaches to a trailer for my jeep it was connected to all the wires for the turn signals in the back of my 88 YJ. I reconnected all the colors back together but for some reason now my right turn signal will barely light up and flickers very quickly. But when I use my hazards both turn signals work fine. If I am driving at night time with my headlight on nothing will work including my brake lights which seem to work fine and also when I am braking my dashboard will light up....

Its all very strange and I have been looking through the wires for a few days trying to see if there are any splices or anything but with no luck

Thanks if you can help that would be awesome

drivebytruckerz 06-10-2010 02:27 PM

Hmm.. good luck. I'm sure somebody more knowledgeable will have some help. Consider this a bump.

PTaylor 06-10-2010 02:45 PM

damn......:confused:


you need to recheck your wiring. unless you damaged something else.

can you disconnect the wires and wire them one at a time to see if something changes? tried rewiring it?

Got_Mud? 06-10-2010 05:28 PM

Check the ground wire only - ground it with a clip lead or even jumper cables - then check it...sounds like the ground is weak/failed and is using the other hots to complete the circuit.... Just a thought...

jr. 06-10-2010 06:08 PM

x2 on the ground it is usually the problem.


All times are GMT -5. The time now is 01:01 AM.