Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Brakes Weirdness: Need some help here. (http://www.wranglerforum.com/f218/brakes-weirdness-need-some-help-here-53397.html)

AlexPerdido 06-19-2010 08:58 PM

Brakes Weirdness: Need some help here.
 
This is my first post, although I often read this forum. Always learn something.

Driving my '95 YJ yesterday, top off, in the sun, loving life. Gradually I notice the engine is struggling a bit, and there's an acrid hot-metal smell. Slow-rolling in neutral, the Jeep stops on a dime like I've stepepd on the brake pedal. Now it's pulling sharply to the right at the slightest press of the brakes, and the funky smell is bad and getting worse. Oh, crap...the brakes are stuck! I drive, slowly and terrified, to my tire shop that also does tuneups and brake jobs, and leave the Jeep there with a full description of the problem. First thing next morning, shop guy calls and says they cannot reproduce the problem. Brakes are working fine. Furthermore, he says he took off the wheels, and the brake pads show no sign of overheating: no glaze, no hot spots, rotors look good. I go the shop, fire up the Jeep, sure enough, everything's perfect. I cannot express my frustration.

Has anyone had this problem, or can share there first thoughts on this weird brake thing? Now I'm nervous about driving the Jeep.

Please advise and thanks from Atlanta.

Pylonpounder 06-19-2010 09:22 PM

The rubber brake hoses are too old and going soft. This happened to me; they won't seem soft, you won't be able to squish them really, but they are soft enough that they swell under the pressure of braking and, after a little bit of driving and, consequentially, using brakes, they hold enough pressure that it's noticeable. Took me two drives to figure it out cuz the first time wasn't long enough for the brakes to start smoking, which is what allerted me, silly me. Check out your hard brake lines too, just to be safe. I blew one troubleshooting when this problem happened to me. the soft brake hoses run from the brake calipers to the hard lines. Quadratec or JCwhitney probably both have them for relatively cheap

beachnjeep 06-19-2010 09:23 PM

if it pulled right hard then you must have had a stuck caliper most likely or a faulty hose(one of the most overlooked items). Yes it can go away as it cools off but might start again as it heats up. Pads at first will not be noticible till it does it a few times. Hopefully they tried to look at the inner pad not just the outer.
Inner pad wear: caliper sticking usually
Outer pad wear: slide mechanism not letting caliper float back and forth as brake is applied.
I would double check and ask them if they looked at the inner pad as most shops can miss that on a quick glance.

beachnjeep 06-19-2010 09:24 PM

dang you typed faster then me :)

hannahuffster 06-19-2010 10:42 PM

agreed with just about everything that has been said. I had the same problem when I got my 93. pulled one way while driving and veered to the other when breaking (especially above 35-40 mph). Changed calipers & soft lines [and went ahead and replaced pads and rotors so everything is new] and now it drives like a Cadillac! I would go ahead and change both calipers and lines when you do it, just to make sure the other doesnt start hanging with one new caliper.

beachnjeep 06-19-2010 10:58 PM

true, always in pairs to be safe

AlexPerdido 06-19-2010 11:43 PM

Wow, great responses and great advice. Many thanks. I will definitely give those soft hoses some attention. Anybody else have thoughts on this?

FyreSarge 07-21-2010 07:11 AM

@ hannahuffster: Did you have any problems bleeding the brakes after replacing calipers and hoses? I have flowed about 3 quarts of fluid trying to get a good pedal.


All times are GMT -5. The time now is 09:03 AM.