Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   o2 sensor help (http://www.wranglerforum.com/f210/o2-sensor-help-56460.html)

p1zzaman 07-27-2010 06:43 PM

o2 sensor help
 
So my jeeps been pulling the p0138 code, and I ordered the sensor from checker yesterday, and I just looked at it and compared to what this website says Experimental Insanity! - Jeep Oxygen Sensor FAQ and its sensor 2 not 1...

I should have
2004: Part #15506
but they gave me
2004: #13687

Will it work? or is this going to cause problems? its the downstream sensor 1 for a 2001, not 2004. But its the downstream sensor 2 for a 2004... I just dont want to install it, have it not work or cause problems, and have them refuse to take it back. These are expensive little buggers, so I dont want to have to buy another one.

jwm1986 07-27-2010 09:28 PM

I wonder if it's a cross reference issue. When I looked up part# 13687 it gave me item#15507.

p1zzaman 07-27-2010 09:32 PM

I couldn't really find anything on it... So I went ahead and swapped them out and cleared the code. So far, the CEL has not come back on but I'm keeping my fingers crossed. If it was the wrong one, wouldn't the connectors not match up? or are all 4 the same? also, wouldn't the CEL just come back on immediately after starting it?

jwm1986 07-27-2010 09:32 PM

Pics of both look the same, I am not sure what the dif would be. Seems to me that as long as it's listed as a downstream sensor it would work fine. They are both 4 wire sensors it looks like.

p1zzaman 07-27-2010 09:38 PM

Quote:

Originally Posted by jwm1986 (Post 703457)
Pics of both look the same, I am not sure what the dif would be. Seems to me that as long as it's listed as a downstream sensor it would work fine. They are both 4 wire sensors it looks like.

Ya, they are both downstream, and both 4 wire. Just wanted to clarify that it would work before I did something dumb like install the wrong sensor.

jwm1986 07-27-2010 09:45 PM

I'm no o2 specialist but i'd say your good then. The CEL should've come back on if not.


All times are GMT -5. The time now is 07:48 PM.