Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   JUMPING RPM's... What's going on??? (http://www.wranglerforum.com/f19/jumping-rpms-whats-going-on-57069.html)

aturner088 08-03-2010 12:47 PM

JUMPING RPM's... What's going on???
 
Alright, I need help. #1 After driving about 25 miles home from work, I pull in my driveway and put The Jeepster in park and the RPM's jump to around 2500 and it just keeps a steady rev untill I put it back in drive or reverse and it kind of thumps. Put it back in Park, same thing, shut it off then it makes a reallt loud "CLANK" sound. #2 Sitting at red lights she jumps. The RPM's go up high and she lunges forward and sometimes shuts off. #3 Merging onto the Interstate (or anytime I need to pick up speed quick) theres a delay, like she cant shift herself or something... And Im the dude holding up traffic because I cant get up to 70 mph in a decent amount of time... She's an automatic (dont laugh) Started all of this about a year ago but it stopped for a while and is back with a vengece=( Please help me help my girl!! Thanks

aturner088 08-03-2010 02:59 PM

And when I just went to lunch she was riding really rough. And the RPM's were still crazy high... Damn mood swing I think.

shawndabrookebays 04-06-2011 10:48 AM

Quote:

Originally Posted by aturner088 (Post 710863)
Alright, I need help. #1 After driving about 25 miles home from work, I pull in my driveway and put The Jeepster in park and the RPM's jump to around 2500 and it just keeps a steady rev untill I put it back in drive or reverse and it kind of thumps. Put it back in Park, same thing, shut it off then it makes a reallt loud "CLANK" sound. #2 Sitting at red lights she jumps. The RPM's go up high and she lunges forward and sometimes shuts off. #3 Merging onto the Interstate (or anytime I need to pick up speed quick) theres a delay, like she cant shift herself or something... And Im the dude holding up traffic because I cant get up to 70 mph in a decent amount of time... She's an automatic (dont laugh) Started all of this about a year ago but it stopped for a while and is back with a vengece=( Please help me help my girl!! Thanks


I had the exact same problem with my 98 XJ. I had it in the shop 5 different times 5 different places trying to fix it. Replaced everything that possibly could make it do that plus a few other things that didnt even need replaced besides the fuel pump and fuel filter. I just sold it but right before I sold it I noticed that it didnt do it when my tank was full of gas. So im thinking mine had something to do with the fuel pump or fuel filter. Fix the less expensive problems you think it might be before you replace the expensive parts.

C.L. 04-06-2011 08:12 PM

Put it in park (running), pop the hood, and actuate the throttle by hand. Is there smooth resistance as you open it? Does it return to its original position or hang up along the way? Is the cable tight or swinging in the breeze? It might be something as simple as crud in the throttle cable sheath binding up the cable, or a weak return spring.

Is the engine light on? Throwing any codes at you?


All times are GMT -5. The time now is 07:04 AM.