Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   92 YJ Slave cylinder issues (http://www.wranglerforum.com/f218/92-yj-slave-cylinder-issues-59941.html)

YJPunisher213 08-29-2010 01:43 PM

92 YJ Slave cylinder issues
 
For the 5th time in 4 months I have had to replace my slave cylinder. It seems to be one of 2 problems. Most of the time it is the O-ring in the slave cylinder hose coming from the master cylinder blowing out. Twice it has been the boot of the slave cylinder itself. I know im installing/ bleeding it correctly. Just wondering if anyone else has had the same issues and knew how to fix it. Thanks!

UABYJ94 08-29-2010 05:48 PM

If you are buying them from your local parts house then this is your problem with them goinng bad so quickly.
Go to Clutchcity.com or carolinaclutch or even rockauto.com and get a better quality hydraulic part. Clutchcity and I believe carolinaclutch both carry oem replacement parts very resonably priced then you can either buy it from them or google online dealerships and get their cost then try to get your local dealer to price match..most of the time they will. If not then smile as you leave to go home and order it.

jgwalt 08-29-2010 06:34 PM

is the 92 an internal or external slave?

YJPunisher213 08-29-2010 07:02 PM

Internal..... Im a pro at trans dropping. Last clocked was 1:45 min lol

YJPunisher213 08-29-2010 07:05 PM

Yeah I got the clutch from them shucks at autozone. When it originaly went out I called everywhere. It was a 5 day wait till a friend called autozone and said I could get the entire clutch kit for less than just the slave cylinder and get it the next day.

YJPunisher213 08-29-2010 07:08 PM

The brand slave cylinder I just installed was a LUK..... Installed it 2 days ago and already leaking


All times are GMT -5. The time now is 10:41 PM.