Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   2007 Sahara Radio not working (http://www.wranglerforum.com/f40/2007-sahara-radio-not-working-60425.html)

PDB 09-02-2010 11:25 AM

2007 Sahara Radio not working
 
Of course just after I pass 36,000 miles, the radio stops working. I have the NAV system and it works fine. I can turn the unit off and on but when turning the volume knob, it does not show the volume bars on the screen. I also do not get any sound at all. I cannot tune the radio either and it will not show what stored stations I did have in there. I can goto the hard drive, juke box and other areas. Have not tried using them but can select and see them like normal. I do not have any files stored on the system. I went into system setup and the audio control button was greyed out like the system is being told its not installed or something.

Every once in a while, after driving for a bit, it may start working and will work fine till I turn the jeep off. Thought about loose wire but once it starts working, continues to work and does not go in and out. Could still be a cause but less likely in my mind anyway.

Is there any kind of hard reset for the system I could try? Any other thoughts or ideas? It is all factory equipment.

Thanks,

PDB

PDB 09-08-2010 11:12 AM

Just wondering if anyone has any ideas? Also found I could plug my phone in and it works fine. Still just seems to be the AM/FM portion not working. Although, I did notice my GPS altitude going up the other day when I was definitely going down hill.

Thanks,

PDB

Jaydogg25 09-08-2010 07:47 PM

doubt it would be a loose wire...unless someone was behind radio and messed with it. most likely (and know you dont want to hear it) probably a internal problem. and no matter what way you go it wont be cheap since it's vehicle newer than 2000 & has a nav. system. unless they changes it. radio & nav are together so it's normaly a complete replace of it all w/ aftermarket or factory which would be probably over 2k for anything decent. and idk about repairing it.. most dealerships just want to swap for X amount of dolars and not many repair shops left.

give you a idea...depending on what shops by you charge.
mounting kit ~ $20-$50
harness ~ $130+ (special harness...saying they even make one that will work sicne you have factory nav.)
if you have steering wheel controls ~ $150
decent aftermarket nav ~$1000+ depending on features you want
labor ~ $200 or so....goin rate here is $75/hour

PDB 09-08-2010 07:56 PM

Thanks Jaydogg25.

You are right, not what I wanted to hear but was exactly what I was afraid of.

Well, maybe it's time to get a 2010 or 2011 Jeep. Gotta do some thinkin here.


All times are GMT -5. The time now is 07:58 AM.