Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   stock radio (http://www.wranglerforum.com/f210/stock-radio-61340.html)

Sblanck 09-11-2010 02:39 AM

stock radio
 
Been having troubles with the radio in my jeep. If I hit a mild bump it will go off. Now If I stop and then turn off the ignition and then restart it comes back on. I did take the radio out and clean it with compressed air and cleaned the harness. It didnt do that for three days. So do you think the radio is bad or the harness is bad? It seems to me the harness is slowly working its way loose even though there is a snap lock thing.

Sean

Jma20a 09-11-2010 10:45 AM

sounds like a bad ground, in mt '99 the tether attached to the back of the unit was the ground connection, take a look and see if it is loose. and be careful with using compressed air some times it could damage some parts on the unit.

Sblanck 09-11-2010 04:56 PM

well seems that might be the problem, the ground screw is gone altogether.

Jma20a 09-11-2010 06:04 PM

what you should do is take the unit to home depot or any hardware store and find a bolt that fits and it has to be short 1/8" bolt at the longest, that or you can just go get a head unit

Sblanck 09-11-2010 08:10 PM

I will just go without for a while and put in a new head unit. Obviously not a jeep one since I could get 4 alpine units for one jeep one.

dutch169 09-11-2010 08:25 PM

I have a stock radio lying in my trunk if you want it.

NM JEEPS 15 09-12-2010 01:08 AM

you know mine was doing the same thing for a while it would be working fine and then I would hit a bump and the rear speakers would just turn off and then flick back on for a sec and then turn off again. i checked all of my wires and tightened them and the next day boom same thing happened. so I said what the heck I'll go get it checked and what do u know they started working fine and I haven't had any problems since then. so I have no idea what I did to fix it!!

Sblanck 09-12-2010 07:32 AM

Yeah its pretty screwy. Every car I have owned the stock radio crapped out and I had to have a new system put in. Kind of tired of doing that because once the new system is in something happens and I have to trade the vehicle in. Its a viscous cycle I would like to not happen with this jeep.

Jma20a 09-12-2010 02:05 PM

^thats why you keep the factory speakers and headunit, and put it back in when you sell your vehicle, and keep the nice stuff.


All times are GMT -5. The time now is 12:55 PM.