Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   2001 TJ with no fuel pressure (http://www.wranglerforum.com/f210/2001-tj-with-no-fuel-pressure-62555.html)

MK17Fan 09-21-2010 04:41 PM

2001 TJ with no fuel pressure
 
My 2001 4.0 auto wouldn't start today. It tried but wouldn't go. I can't hear the fuel pump hum. I took my YJ to Advance and picked up a fuel pressure test gauge. I've got no fuel pressure at the rail. I have swapped all of my relays around to rule them out. Also swapped the horn and fuel fuses to rule that out.

On the dash, the key light comes on and stays on to indicate a problem with the electronics and then the gas light comes on after that. It has gas in it. I added a couple gallons to be certain of that. There are no codes to pull and the check engine light isn't on.

Does this mean I have a bad fuel pump?

Jerry Bransford 09-21-2010 04:50 PM

You might have a bad fuel pump but disconnect then reconnect its electrical connector first to make sure the connector isn't just dirty or not completely connected. A test light would indicate if it's getting voltage, measure it as someone turns the ignition switch to On. It is only powered for about a second so you'll need to have the test light or volt meter connected when the key is first turned on.

There are four connections inside the fuel pump's connector... two grounds, one to the fuel pump and the other leads to the gas gauge sender.

MK17Fan 09-21-2010 05:01 PM

Is this something I can access without removing parts to get to it?

Jerry Bransford 09-21-2010 05:09 PM

1 Attachment(s)
It's been a while but you may be able to snake your hands up high enough to get to the connector for the fuel pump. The connector is very close to the front-top edge of the tank.

Even if you can't get to it, you can get to the wiring leading to the tank and fuel pump to see if there is +12v going to the fuel pump when the key is first turned on.

You can see the connector at the very top of this photo I took while replacing the pressure regulator.

MK17Fan 09-21-2010 05:30 PM

Thanks for the instructions and the pic. I can get to the connector. How do I move the red thing to unlock the connector? I don't need to break it. :)

Jerry Bransford 09-21-2010 05:35 PM

Quote:

Originally Posted by MK17Fan (Post 782009)
How do I move the red thing to unlock the connector?

I'm an electrical kind of a guy and have been around various connectors for 45+ years but those little red tabs Jeep uses in their connectors to lock them together drive me nuts. Just when I think I've got it figured out, the next red tab seems to work differently and I struggle madly until I finally somehow get it apart.

In other words, if you figure it out, please let me know what the secret is. :rofl:

MK17Fan 09-21-2010 06:04 PM

Ok I used the flat blade of a screwdriver to apply pressure to the side of the red tab with the hole in it. It pushed the solid end out and allowed me to disconnect the connector. The connector appeared ok and was nice and clean inside. I reseated it and tried starting. No go. I did notice that the check engine light does come on after the other 2 lights come on. Perhaps I didn't see that before?? My Actron OBD II Scanner is unable to connect. It keeps giving me an error and asks me if I want to check connections and try again.

Jerry Bransford 09-21-2010 06:10 PM

You can display your own codes by turning the ignition switch on-off-on three times within five seconds and then waiting for the codes to start displaying in the odometer. Leave the key in the On position after the last on-off-on sequence. Be patient, they don't show up immediately... the computer has to go through a routine before any codes present will display.

MK17Fan 09-21-2010 06:43 PM

I'm having zero luck getting any codes to come up. I've tried about 10 times but I must not be holding my mouth right.

Jerry Bransford 09-21-2010 07:05 PM

The code feature was missing from '98 to '00 but I thought it was back by 2001. That ability must have come back only after yours was made, sorry about that.

I would probe that connector or the wiring leading to it for +12v. The black wire leading to the connector is ground, the dark greeen wire with the white tracer is what provides +12 to the pump itself. The darkblue/light green tracer and the black/light-blue tracer wires are for the fuel pump gauge sender.

Also put your finger onto the fuel pump relay inside the power distribution sender. You should be able to feel or hear a soft click inside it as it is energized by turning the ignition switch on if the ASD relay is functioning properly.

MK17Fan 09-22-2010 08:54 AM

I can't seem to locate my voltmeter this morning. When it rains..... Hopefully it will turn up today or I'll beg, borrow, or buy another one.

MK17Fan 09-22-2010 06:24 PM

With the voltmeter set to V~, I got no voltage reading from the wires going to the fuel pump. A check of the battery tells me that the meter works. So, this means that the problem is not the fuel pump but something prior, yes?

Jerry Bransford 09-22-2010 06:28 PM

Yep, it doesn't sound like the fuel pump is the problem if it doesn't get +12v for 1-2 seconds after first turning the ignition key to the On position. Check that the fuel pump relay inside the power distribution center is energizing, which also requires that the ASD relay energizes.

MK17Fan 09-23-2010 06:16 AM

I had the wife help me check to see if the relays were clicking on. I felt the ASD relay and Fuel relay as she attempted to start the Jeep. I felt absolutely nothing. Is there a fuse or reset before the power distribution box?

Jerry Bransford 09-23-2010 09:41 AM

Check the 30A fuse in location #9 and 20A fuse in location #23, both of which are inside the power distribution center under the hood. Both fuses control the fuel pump and asd relays as well as the PCM. Might as well check all fuses and that both relays sockets are clean and not corroded.

MK17Fan 09-23-2010 10:44 AM

All of these look good. I removed them, swapped 30a for 30a, 20a for 20a, and verified the connections are not corroded.

Jerry Bransford 09-23-2010 10:50 AM

It is time to engage the services of someone more technically oriented who can troubleshoot what is in reality a simple electrical circuit.

rrich 09-23-2010 11:09 AM

On the top part of the relay box - on the end - there are 2 large wires on terminals. Remove them, clean and reattach. Even when they look good, they can cause all sorts of problems.


Pop the upper part of that relay box off - there are snaps that hold it in place. Carefull pulling it up to see under it.
Inspect the bottom of the relay and fuse sockets. Corrosion seems to be a common problem. ANY green or white stuff needs to be removed.

Use a good contact cleaner - or in a pinch - believe it or not - Taco Bell hot sauce (mild) eats the corrosion (or vinegar.) Spray it down with contact cleaner to neutralize the hot sauce. (He He - dip an old penny in it - it comes out shiny new! And we eat that stuff!)

Don't use WD-40 - it attracts moisture and will cause more corrosion eventually.

MK17Fan 09-23-2010 12:17 PM

The terminals going to the power dist box were clean. I took them off and inspected them. All contact surfaces were shiny. I had already took the bottom off the box and looked at the wires going into it this morning. They were all clean. It's still giving the same symptoms.

Perhaps I'll take the ECM off the wife's LJ when she gets home and see if it's the ECM. Good idea or no?

Jerry Bransford 09-23-2010 12:47 PM

Doubtful your LJ's PCM will work in your TJ unless both are from the same model year, engine, and transmission type.

MK17Fan 09-23-2010 12:57 PM

Ok. They are both same engine and both automatic but not the same year or the same model transmission. It's getting down to the point where I either need to get it towed and have a professional work on it, or take a chance on another PCM.

MK17Fan 09-23-2010 05:32 PM

Thanks for all the help. I did more searching today and used different search terms and determined that I have a bad crankshaft position sensor. When I unplugged it, my error lights quit showing up and my code reader worked again.

I would post links to what I found but it's on another forum site and another site with how to's. I'm not sure if it's ok to post such links or not.

Jerry Bransford 09-23-2010 05:38 PM

Even with a bad CPS your fuel pump should cycle on-off when you first turn the ignition switch to the On position.

MK17Fan 09-23-2010 05:50 PM

Here's where I got my information.

4.0 will crank but won't turn

I won't know for 100% certain until I get the part and put it in. It might be tomorrow morning for that.

Jerry Bransford 09-23-2010 06:11 PM

I am very familiar with the CPS and what it does and what happens when it's not working. Have you suddenly forgotten your fuel pump isn't turning on at all? Not even with the initial On sequence when it momentarily turns the fuel pump on and then back off a second or two later? The fuel pump will turn on like that even if the CPS is completely missing. Your CPS is not causing your fuel pump to not turn on.

The ASD relay will shut the fuel pump off if the CPS signal is not present LATER, but no matter what, the fuel pump will always quickly turn on then off when you first turn the ignition switch to the On position. Whether the CPS is working, dead, defective, or missing, the fuel pump will still turn on when the key is first turned on. From what you say, your fuel pump is never turning on... a bad CPS won't cause that.

MK17Fan 09-24-2010 07:54 AM

I hadn't forgotten about the pump not running but under symptoms of the other post it lists:

Symptoms
-Starter cranks and cranks but engine won't start up
-Fuel gauge and voltage gauges may not work or display properly.
-You sometimes will have No Bus on the odometer after 30-60 seconds.
-No spark at the spark plugs.
-Fuel pressure is OK at the fuel rail. There have been some instances where the fuel pump does not prime or run when the CPS is failed.

so I unhooked it as the post went on to suggest and the error lights went away and the gauges started working properly last night. This led me to believe that the CPS might very well be bad and if so, it wouldn't hurt anything to replace it.

I went ahead and swapped that CPS out this morning. As soon as I turned the switch to "ON", I could hear the click of the relay and the hum of the pump. The Jeep started within a few seconds of cranking.

I know very little about this stuff but I figured I could take a chance on a $45 sensor.

Again I thank you for all the suggestions and the moral support to work through it and find a solution. Even a blind squirrel will find an acorn now and then.

Jerry Bransford 09-24-2010 10:37 AM

That is great news, good job. In going over the schematics of that circuit and reading the FSM's description of that circuit, I didn't see how the CPS could cause the fuel pump not to cycle on before starting the engine but in your situation, it apparently did. It just goes to show that sometimes, all the theory in the world isn't always 100% reliable. Thanks for the update! :)

rrich 09-24-2010 11:07 AM

Save that sensor please! The only way I can see that the CPS could cause the pump to not run is if the winding inside the sensor shorted to ground. That might cause the 5 volt buss to drop (that's the supply voltage to the sensor,) causing the PCM to shut down other functions, like the ASD. Almost EVERYTHING uses that 5 volt supply.

Try seeing if there's continuity between one of the sensor's wires to ground. It should be infinite resistance.

That might be good to know if another sensor shorts to ground, like the MAP or TPS and causes the same symptom.

Otherwise it's something got bumped or moved when troubleshooting and replacing the CPS. If that's the case, it will rear it's ugly head again someday.

I do know when you short out that 5 volts to ground the engine stops. I was experimenting with a series resistor in the MAP circuit to enrichen the mixture slightly and shorted the wires. The engine shut off! I was in traffic and realized what I did and immediately uncrossed the wires. Never did determine what it affected, it may have been the ASD system.

Please - measure and let us know.
Thanks, Rich

MK17Fan 09-24-2010 08:33 PM

I kept the sensor. I took my friend's voltmeter back before I saw this last post. Maybe I'll find mine soon.........


All times are GMT -5. The time now is 02:54 AM.