Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Has trouble in the morning (http://www.wranglerforum.com/f218/has-trouble-in-the-morning-62560.html)

Raithe79 09-21-2010 05:04 PM

Has trouble in the morning
 
I leave for school around 7 a.m. and my 94, 2.5 has some trouble. As i let out the clutch and give some gas, the rpms bog down past 1000 idle rpm as if stalling out. I push the clutch back in and it saves it. I have to push the throttle to get it into first. After that, on the road i accelerate and the jeep kicks back and forth because the rpms drop quickly to about 1000 and then back up to where it was. It does it in second gear as well.

Im wondering if its a moisture problem because of the dew in the mornings, maybe the distributor. It does not do it later in the day. Anybody have any suggestions? Input would be greatly appreciated

Rebuilt 09-21-2010 10:33 PM

Try changing your spark plugs and work your way from there

Schwheelz 09-21-2010 10:43 PM

Try the spark plugs first they're easy to change and cheap:) after that I would be convinced it's your battery

Rebuilt 09-22-2010 12:26 AM

Also make sure your timing is correct

Matt The Hammer 09-22-2010 02:50 PM

There's a few different things it could be. I had the same issues and reside nearby.

Morning moisture will affect your distributor/rotor.

Does it start up quickly in the morning or does it crank for a while? I recently rebuilt my computer (for less than $10) and it solved a lot of the morning issues.

smittyzz 09-22-2010 02:52 PM

my dads jeep comanche takes a while to start.. its cranks for a bit.. any clues why? ditributer?

NAVYCHIEF 09-22-2010 03:01 PM

allow 3-5 secs after turning key on. it takes that long for relays and fuel flow to get to the engine. an old fuel filter may also be the culprit.

smittyzz 09-22-2010 03:10 PM

aha!i will go try that now! thanks and will post how it works! :D

smittyzz 09-22-2010 03:13 PM

alright so after acually listening to the fuel pump i heard it, never have before. and it takes like 2-4ish seconds to turn on

Matt The Hammer 09-22-2010 03:26 PM

When your turn your key to the 'on' position - not start - the 'check engine' light should come on immediatley. That's when the CPU has power. If it takes a few seconds, the capacitors on the board are problably worn and should be replaced.

Google for the repair - I found great detailed threads on another board. Both for the diagnostics and the actual repair.

smittyzz 09-22-2010 03:33 PM

lemme go check!

smittyzz 09-22-2010 03:38 PM

its a 1990 jeep comanche lifted, used to have death wobble but fixed it be ballence, alignment. and when i turn the key to on, the busser stays on for a sec and i dont ever see the check engine light?.

Raithe79 09-22-2010 04:04 PM

Hmm. I replaced all starting parts besides the coil. But the check engine light does come on. It could be a bad fuse.


All times are GMT -5. The time now is 07:06 PM.