Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   WF New Member Check In (http://www.wranglerforum.com/f12/)
-   -   New to Forum with a question about my 93 Wrangler (http://www.wranglerforum.com/f12/new-to-forum-with-a-question-about-my-93-wrangler-63629.html)

tlynn77 09-30-2010 12:29 PM

New to Forum with a question about my 93 Wrangler
 
Hello out there fellow Jeepsters. I'm from Northern California and I have a 1993 jeep Wrangler 4 cyl 5 Spd 2.5 ltr.
Lately I've noticed that my check engine light comes on and that I'm going through a lot of oil with no apparent leakage places. However I did notice that there is a lot of oil building up in the breather. I took it out and cleaned it with hot soapy water and then let it dry before replacing it. The check engine light went off. Then after no more than a couple of hundred miles the light came back on and the breather was full of engine oil again. Any ideas how to solve this without payinga mechanic? Thanks all.

blkrubi88 09-30-2010 12:43 PM

Welcome to the forum! You might want to post your question in the YJ section for better response if you don't get an answer here!

Ageless Stranger 10-01-2010 01:05 AM

Welcome to WF. :wavey:

Yjwolf 10-01-2010 03:20 AM

Common problem with both 4 bangers and 6 cy. There's a build up of gunk in your valve cover preventing ventilation. It's like haveing a bad PVC valve. Pull the cover clean it up real good and it should fix it. Had this prob with my 4.0 and my dads 4cy


All times are GMT -5. The time now is 09:45 AM.