Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   New Hydraulic Clutch leaks! (http://www.wranglerforum.com/f218/new-hydraulic-clutch-leaks-63778.html)

89WranglerCJ 10-01-2010 08:09 PM

New Hydraulic Clutch leaks!
 
I just need someone to give me the bad news. I need to hear it from someone else. I just finished putting in a new clutch, pilot bearing and hydraulic clutch bearing (getting the tranny out and back in over the exhaust pipe was fun:), torqued everything down, topped off all the fluids and when I went to bleed the clutch, hydraulic fluid (brake fluid) started dripping, almost pouring, out of the tranny clutch housing. Soo after three days of work, I just need to accept the fact that either the quick fittings on the clutch hydraulic bearing didn't seat the hydraulic lines correctly or I bought a bad unit. The lines were pretty loose when I was installing the unit, but they were loose on the old one so I didn't get too concerned. Guess I should have been. If I had a nice lift to work under doing the whole thing over again wouldn't seem so dreadful, but I'm not looking forward to laying on my back with the tranny in my lap, again. Anyone done a hydraulic clutch lately and had the same problem?

45 ACP 10-02-2010 07:06 AM

I just replaced my in my 91 YJ with no problems. Sounds like you may have a line leaking. Where did you get the slave cylinder? Looks like you will have to pull the tranny again. It helps if you remove the exaust unbolt the front pipe at the header and get it out of your way. Also I used a transmission jack and this it a big help if you are doing it by yourself. Some people remove the transfer case from the transmission to lighten up the load. Good luck!!

89WranglerCJ 10-02-2010 12:39 PM

Thanks buddy,
You're right, I have to pull it, again, and I may take a look at pulling the exhaust, too, if the bolts don't look too bad. But overall, I'm an idiot. It wasn't a leaky line. I've never done this particular job before and it's been a few years since I've done any hydraulic work so I read my shop manual and the installation directions for the parts very carefully, but unfortunately there was no mention of O RINGS!!! I was just out in the barn picking up tools and regrouping when I decided to examine the old hydraulic bearing especially where the lines are seated and that's when I realized what I had forgotten. I looked in the new clutch kit box and under all the cardboard and paper I found a little baggie of...yup, O rings. I should have known better, but like I previously stated: I'm an idiot. Well, I'll let this be a lesson. And, I'll try to look on the bright side. At least, I know I have everything I need and won't have to run (walk) into town for little odds and ends like gear oil or lock-tight. Thanks, again, for the advice.

Keep the rubber side down,
CJ

IdahoIslander 10-02-2010 01:00 PM

Got our '89 YJ new and the hydrolic clutch failed one night in '93 when we left a resturant, Had to tow it home w/ a friend's truck and fix it.
Just dropped a remanufactured 4.2 in this spring (because of compression issues) and replaced the clutch at the same time- made it for about 3 1/2 months before the new slave cylinder failed. My friend that helped me with the engine is putting in a warranted replacment this week. Hope to be back up and running within a few days. All said and done - I'm pretty happy with the 18 years that I had no clutch trouble. And sometimes I really POP that clutch and bark the tires in 1st and 2nd for my more civilized friends.


All times are GMT -5. The time now is 04:02 PM.