Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Stupid Disco Questions (http://www.wranglerforum.com/f210/stupid-disco-questions-64758.html)

Dockman4 10-10-2010 03:55 PM

Stupid Disco Questions
 
When I got my TJ 2 months ago, I had a broken sway bar link and I replaced both of them with stock links. Now, after getting on this forum, I've decided I need to get rid of those and purchase disco's, especially when I put on my coil spring lift (which is the direction I think I'm going). Question, probably stupid, but I honestly don't know, what do you do with the sway bar when you disconnect the links? Does it just stay where it is? Do you swing it up or forward? Does it interfere if you don't? :confused:Also, what about the link itself, where does it go? Thanks. I've just been wondering this and I couldn't find it anywhere.:crash:

Jerry Bransford 10-10-2010 04:00 PM

Good discos include a way (like a frame-mounted stud) to support the antiswaybar on both sides when it is disconnected. Look at those from JKS and Rubicon Express, I'm pretty sure they do.

TXRIDER 10-10-2010 04:39 PM

The Rubicon Express include a stud that you drill and mount to the inner fender. When you disconnect you just fold the link up and re-pin it. easy to do just have to keep a adjustable wrench with you to loosen and tighten the jam nuts when moving the links. So far I am happy with them.

Dockman4 10-10-2010 05:21 PM

Thanks for the info. I'll check out the RE disco's.

bc40ton 10-10-2010 05:46 PM

Just installed the RE disco's. Had to do some fitting. And I didn't like where they suggested to anchor the stud. So I cut out some brackets and welded to the shock tower. No hand tools, just a slip fit to connect/disconnect.

http://i281.photobucket.com/albums/k...Jeep/disco.jpg

outta the way

http://i281.photobucket.com/albums/k...eep/disco1.jpg

Dockman4 10-10-2010 06:33 PM

Oh I like that idea. Thanks bc40ton.

InfernoGirl 10-10-2010 09:11 PM

Low tech solution is to zip tie them out of the way.....

Brorthopa 10-10-2010 11:29 PM

I have the JKS quick discos and I just drilled a hole, popped in some drywall anchors w/ screw and some heavy duty Velcro straps & it works just fine. Is it the coolest looking? No, but no worries! Good luck!

Minn_wild1 10-11-2010 06:37 AM

Quote:

Originally Posted by Dockman4 (Post 812070)
Oh I like that idea. Thanks bc40ton.

X2. This looks like a good set up.

530ktm 10-11-2010 09:55 AM

JKS comes with a threaded stud you mount to the frame rail. You have to drill a hole and thread in but it keeps everything out of the way and is very easy to do. I have seen some people put this mount in the inner fender only to have the tires rub when at full turn, not good. Follow the directions and you will be fine.

jgorm 10-11-2010 11:26 AM

I have the JKS quicker discos and there was no good place where the mounting stud would fit without modifications. I think it may be due to my lift height (2.5"). I have some string to tie them out of the way.

NHrubicon 10-11-2010 12:01 PM

I have the JKS quick disconnects, mounted the pin forward on the frame rail like they said, and yes, if I really crank the steering wheel with 12.5" tires they rub on the sway bar, but no matter WHERE you put the pins, that sway bar is going to be in the same spot and will get rubbed. Just don't crank it or else adjust your steering bumpstops-easy enough to do. As for having to adjust (with wrench) each time you use them-that shouldn't happen-you don't drill and mount the pin until the disconnects are set for the correct height...THEN you move them forward to mark for drilling the hole.
Been running them since BEFORE I put a 4" lift on and we only had to do some minor adjustments on them afterwards-but the pin spot still works exactly like designed.

Jerry Bransford 10-11-2010 01:15 PM

I'm not saying the stud was mounted in a different location than instructed but the only time I had this problem, interference between the stud and tire, was when I installed the stud too low on the frame. I was embarassed when I discovered after re-reading the instructions that I should have mounted the stud at the very top of the frame. Once I moved the stud to the correct location per the instructions, I had no more clearance issues between the tire and the stud.

Dockman4 10-11-2010 01:18 PM

Tahnks for all the advice. Looks like JKS is the way to go!?! Sounds like alot of people like them.


All times are GMT -5. The time now is 08:22 PM.