Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Issue with retention clip on the soft top Door Surrounds. (http://www.wranglerforum.com/f274/issue-with-retention-clip-on-the-soft-top-door-surrounds-65394.html)

bwyman74 10-15-2010 02:36 PM

Issue with retention clip on the soft top Door Surrounds.
 
So I just put my soft top on for the first time ever. Everything works perfectly with the exception of when I try to do just the sun-rider part back. The right side door surround retention clip holds the rail firmly in place, the left side clip allows the bar to pop-out with the slightest touch or wind.

So how are these suppose to actually work. I'm guessing this one my be bad from the factory as I literally just took it out of the box. With the exception of going to to the dealer and having to do warranty paper work to get new surrounds does anyone have any suggestions? Does anyone else's retention clip not hold the bar tightly in place? :confused:

Hiker 10-15-2010 04:20 PM

It may be just that the latch is not fully engaging in the first place.

We also had that happen to us at first, but then after playing with it for a little bit, I noticed that the pin wasn't fully seating all the way through the hole.

In our case, all it took was just a little more wiggle to finally have it snap tightly in place.

InfernoGirl 10-15-2010 04:23 PM

That would be my guess as well... confounded new tops are way more complicated than the TJ tops.... :(

bwyman74 10-15-2010 04:58 PM

Quote:

Originally Posted by Hiker (Post 821766)
It may be just that the latch is not fully engaging in the first place.

We also had that happen to us at first, but then after playing with it for a little bit, I noticed that the pin wasn't fully seating all the way through the hole.

In our case, all it took was just a little more wiggle to finally have it snap tightly in place.

Yeah we jiggled the crap out of it and snapped and re-snapped it with no luck. Ill try some more tomorrow before I give up and take it to the dealer.

Also in a slightly related note. When the sunrider is back and the pins are working properly, should you be able to just flip the sunrider forward and have the front windshield latches reach without undoing the back?

Hiker 10-15-2010 05:05 PM

Quote:

Originally Posted by bwyman74 (Post 821794)
Also in a slightly related note. When the sunrider is back and the pins are working properly, should you be able to just flip the sunrider forward and have the front windshield latches reach without undoing the back?

Yes! :)

Hiker 10-15-2010 05:24 PM

On a followup to your original locking clip problem...

Here's just another thought before you take your Jeep back to the Dealer..

First, try undoing everything on the back end of the Jeep (take out all the windows, release the back side sails and flip them up onto the top rear of the soft top).

Once you do this, the entire soft top should now move very freely.

Next, try one more time to hook those two side clips.. if you still can't get them to lock tightly.. you probably really do have a problem that they Dealer will need to fix.

Good Luck!

Ronin 10-16-2010 02:36 AM

I had this problem with my 09 x. I ran out of ideas and brought it to the dealer. They acted surprised like they have never had this problem before so they "adjusted" the bar and clip. All they did was take a file to the plastic surrounding the hole on the bar. It never did fit quite right. Hope your top gets better service than mine did. That was my first warranty job less than a month after I bought it.

bwyman74 10-16-2010 07:07 AM

Quote:

Originally Posted by Ronin (Post 822474)
I had this problem with my 09 x. I ran out of ideas and brought it to the dealer. They acted surprised like they have never had this problem before so they "adjusted" the bar and clip. All they did was take a file to the plastic surrounding the hole on the bar. It never did fit quite right. Hope your top gets better service than mine did. That was my first warranty job less than a month after I bought it.

If mine doesnt work perfectly Ill demand a new one. Hell it's a 112 dollar part thats seriously overpriced at that price. That thing couldn't have cost them more than 30 dollars to make.

Id like to try filing it myself, but that's a sure way for them to deny my warranty claim.

InfernoGirl 10-16-2010 08:39 AM

Just keep in mind a new one may not be any better. We bought a brand new Mopar top from the dealer.... (long story) When it came in, the holes in the frame were drilled in the wrong place, and it was missing holes in another place. Chrysler wouldn't warranty the incorrectly drilled holes, so we had to redrill in the right spot. They did however replace the part that was missing holes..... :(
I'd run by the dealership and take one off another Jeep, see if it works properly, and if so, then get 'em to swap you.....

bwyman74 10-16-2010 10:18 AM

Well after a night of having the soft-top on the jeep in the up position the retention clip now works perfectly! Go figure. I just hope whatever changed stays that way.

daggo66 10-16-2010 11:42 AM

It must have been the threats of taking it to the dealer.

InfernoGirl 10-16-2010 12:01 PM

Sounds like it wasn't getting seated properly. We had similar trouble. Once we (he) figured out how to get it to seat right, it works beautifully. :) (He's a smart man :))

bwyman74 10-16-2010 01:44 PM

Quote:

Originally Posted by InfernoGirl (Post 822824)
Sounds like it wasn't getting seated properly. We had similar trouble. Once we (he) figured out how to get it to seat right, it works beautifully. :) (He's a smart man :))

That's very possible because I was originally trying to latch it with the sunrider section open. With the top completely closed it seems to click right in. Although the right side clicked right in with the sunrider open. :doh:


All times are GMT -5. The time now is 07:42 AM.