Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   No power to my fuel system? (http://www.wranglerforum.com/f218/no-power-to-my-fuel-system-6674.html)

the idiot magnet 03-18-2007 04:10 PM

No power to my fuel system?
 
I have a 2.5L in my 95 Wrangler and I can't get any power to the relay in the fuse box under the hood which means I don't have any power to get this thing running.
I've swapped or replaced the following: Fuel pump, fuel filter, rotor, relays, crank position sensor, and several other parts including another ECU.
Still nothing!

Any ideas?
I'm getting spark.
Where is the ground for the fuel pump?

kyle 03-18-2007 04:23 PM

well first thing is how much spark are you getting, and the ground for the pump is in the harness that plugs into it. you should get a bright blue spark if you dont have a spark tester just pull one out and put the wire on and ground it out while somebody cranks the motor and see what it looks like. What relay is not getting power??

the idiot magnet 03-18-2007 04:56 PM

The fuel pump relay is not getting anything.
I'm getting a spark, but it's tough to say how strong the spark is. I do the old school screwdriver to some metal in the end of the plug wire.

kyle 03-18-2007 05:27 PM

i dont suppose you have a power probe do you? if you do you can check for power and ground. you should check the wires and look for fuseable links that might have blown. get a can of starting fluid and see if it will start with that (spray it in the intake as close the the throttle body as possible). if it does then just run the fuel pump on a toggle switch.


All times are GMT -5. The time now is 08:12 AM.