Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Speedometer problems with 88 yj (http://www.wranglerforum.com/f218/speedometer-problems-with-88-yj-66751.html)

tannerh2 10-26-2010 08:33 PM

Speedometer problems with 88 yj
 
Hey guys, i'm new to the forum and jeeps in general, but i'm lovin my yj so far. however, i'm having problems with the speedometer. when i'm driving at low speeds, it just flips wildly up and down about 20 mph at a time. it just randomly jumps around, really. it works somewhat well at speeds above 50 though. i checked the speedo gear and it looked totally fine. i spun the gear/cable output manually and the speedometer moved but in the same wild way. any thoughts?? do i just need a whole new speedometer gauge? thanks!

uplifted 10-26-2010 08:40 PM

I have seen it happen when the speedo cable starts to bind.. Try pulling the cable out it's housing.. clean, lube and reinstall... It'll cost you nothing and worth a try.. If you do end up needing a speedo head, i have one..

tannerh2 10-26-2010 08:43 PM

ah thanks a lot i'll give that a try tomorrow!

tannerh2 10-27-2010 01:43 PM

so i tried pulling the cable and greasing it up, but that didn't change anything. the gear still looks totally fine as well. is it possible that i just have the wrong gear in there? it's the one that was in there when i bought it but should i consider getting one with a different tooth count? i have a feeling this one might not be right...


All times are GMT -5. The time now is 08:59 PM.