Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   '05 TJ Stalling While Decelerating (http://www.wranglerforum.com/f210/05-tj-stalling-while-decelerating-70380.html)

TigerTJ 11-28-2010 01:05 PM

'05 TJ Stalling While Decelerating
 
Really need some help here.

Ok, I replaced the battery in the Jeep yesterday. As soon as I got out of the driveway afterwards, pulling up to a stop sign, stalled. Still have power (electrical) but no engine. It has happened about 15 times since. Every time, same thing... Foot on the brake, not touching the clutch, slowing down either for an exit off the interstate, stop light, making a turn....DEAD. I've done some digging around to find some possible solutions, but I've got a gut feeling it is an issue with the new battery, see as it has never been an issue before. Any help would be appreciated, especially because I lose power steering when this happens... not so fun with you are on an onramp going 45 or so getting onto the interstate.

Thanks is advance. Also, new guy here... Glad to be aboard.

ggross 11-29-2010 05:46 AM

your alternator should power it after it is started so i dont think it is your battery. if you dont have power to crank the engine over after it stalls it would be your alternator. or maybe something got reset on you computer from having the battery unhooked.

TigerTJ 11-30-2010 10:49 AM

Yeah, it didn't really make sense to me either.... I've fixed it though. I'm not sure how, pulled a couple of sensors and reconnected them and checked the throttle cable. Runs like a champ now.... weird.. Thanks for the suggestions though.


All times are GMT -5. The time now is 05:53 AM.