Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Different Slave Cylinders??? (http://www.wranglerforum.com/f218/different-slave-cylinders-7122.html)

trulefty 04-06-2007 10:22 AM

Different Slave Cylinders???
 
I have a 88 YJ 4.2 5spd I 've read where other people have had the same problem I'm having, transmission will not go in gear when warm and in neutral. Shifts fine when cool and if you put it in first while still rolling.

I had a new clutch, pressure plate, t/o brg, pilot bearing and the flywheel resurfaced when I did an engine exchange about 2000 miles ago. When the problem started I bled & bled the system then changed the fluid in the tranny and then the clutch master cylinder. So... it has to be the new slave cylinder going out. Warranty will be no problem parts people said they will give me a whole new clutch kit at no charge. However, I'm still going to have to pull the transmission myself. I had someone else do it last time. Are there different types of slave cylinders, meaning is there one better than others or did I just get lucky and get a bad one? Anyone know where there is a post on removing the transmission or can you offer some good advise?
Thanks.

RednekYJ 04-06-2007 03:53 PM

You got a bad one it sounds like. Dont know if there is a better brand, I guess it depends on what clutch you buy. Your sure its the slave cylinder? Is there fluid leaking where the bellhousing and tranny meet?

greasem0nkey86 04-06-2007 07:35 PM

my 93' had a bad slave, broke internally and it didnt leak (i have the internal slave)

when cold it would shift fine, drive fine, only reverse would grind, then after 10 minutes of driving, it would be hard to get into any gears, execpt when the car was moving

one theory i kinda came up with, not sure if its right or not, if its the internal slave, there's these 2 tabs holding the slave in, when you do a tranny, the tabs should be holding the slave in, and when you go bleed the clutch it should pop off

how did i come to this?

before my clutch job, it was driving fine, then my dad did the clutch, and i'm pretty sure (not 100%) he didnt have the slave held back with the tabs, and when the transmission went in, might've went in cockeyed

then again i could be wrong..........

greasem0nkey86 04-06-2007 09:23 PM

oh and make sure to order the right year, apparently jeep went through many different styles

ordered a 92 by accident and it didn't work with a 93, and 94 up they changed to external slave (it was 94' right?)


All times are GMT -5. The time now is 10:13 AM.