Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   O2 sensor failure csuses? (http://www.wranglerforum.com/f282/o2-sensor-failure-csuses-72146.html)

4x4junkie 12-14-2010 12:37 PM

O2 sensor failure csuses?
 
99 TJ 2.5 Liter
Ok what can cause the O2 sensor to fail?? Besides coolant leaking into engine
I've already changed the number 1upper sensor twice and it keeps failing after 2-3 days

I'm going crazy, just had engine rebuilt and blown head gasket work completed.

I can't figure it out need help!!!

Schmo 12-14-2010 12:44 PM

When my cat failed, it took out the O2 sensor. Pretty common issue from what I've seen with the cats not holding up, and apparently when they start to go, they can damage the sensor. Not sure if that has anything to do with your issue though.

4x4junkie 12-14-2010 01:22 PM

Quote:

Originally Posted by Schmo
When my cat failed, it took out the O2 sensor. Pretty common issue from what I've seen with the cats not holding up, and apparently when they start to go, they can damage the sensor. Not sure if that has anything to do with your issue though.

Wouldn't the back sensor go bad too??
Code is only telling me front one the number 1.

Schmo 12-15-2010 07:27 PM

Sorry man, that's the only experience I've had with O2 sensors . . . anything thing else and I'd be talking out my ass.

rrich 12-15-2010 07:48 PM

Why do you think it's a sensor failure? Misinterpreting the code?

What code are you getting?

4x4junkie 12-15-2010 11:10 PM

Quote:

Originally Posted by rrich
Why do you think it's a sensor failure? Misinterpreting the code?

What code are you getting?

Well it's not a code the expensive computer diagnostic my uncle has actually tells us it's o2 sensor # 1.

rrich 12-15-2010 11:19 PM

What are the symptoms you are experiencing? Trouble running?

Failing how? What tests?

After so many sensors I'd think something else is making it look like it's failing, if at all.

4x4junkie 12-17-2010 09:26 PM

Quote:

Originally Posted by rrich
What are the symptoms you are experiencing? Trouble running?

Failing how? What tests?

After so many sensors I'd think something else is making it look like it's failing, if at all.

Engine shakes a little and I hear a weird rattle coming from the exhaust.

rrich 12-17-2010 10:38 PM

What is his scanner showing for that O2 sensor- voltages, cross counts etc?


All times are GMT -5. The time now is 02:49 PM.