Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Loosing power to radio, cig lighter, and turn (http://www.wranglerforum.com/f218/loosing-power-to-radio-cig-lighter-and-turn-73633.html)

ksplayland 12-28-2010 02:15 AM

Loosing power to radio, cig lighter, and turn
 
Hello- So I have a 1994 YJ and as it turned colder my radio will not work when I first start the Jeep, after a minute or two it comes on. Now if I use a turn signal it looses power, or use power outlet, or adjust my blade it temporarily looses power to radio and power outlet. Sometimes it is a short delay and sometime it takes several minutes to get power back. Any ideas?
Thanks for you help!

chensley 12-28-2010 11:19 AM

sounds like its shorting out when a load is put on your electrical system. I'd start checking fuses, grounds, and other junk also..make sure you have the CORRECT fuses in their proper spots. I know it's not a very systematic answer, and someone else will eventually chime in and give you a more direct answer.
Keep an eye out for any traces of water near the fuse box in the drivers side, and also the PCM on the passenger side engine bay.
Good luck, and welcome .

ksplayland 12-28-2010 02:12 PM

Thanks so much. I will do just that and see where i get! Happy Day!

Garyk 12-28-2010 04:42 PM

Sounds like a bad connection(s) or corrosion at the fuse box..

wickedyj95 02-11-2012 06:11 PM

true cold shrinks things and heat makes them expand this could becausing your connection loss. do as these guys said and start small with the fuse block and its conections i would pull each fuse one at a time and clean the contacts with steel wool or an abrasive equal. reinstall wait for cold .lol


All times are GMT -5. The time now is 04:53 PM.