Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Wipers work then they dont (http://www.wranglerforum.com/f282/wipers-work-then-they-dont-77046.html)

99wranglertj 01-23-2011 05:38 AM

Wipers work then they dont
 
My wipers seem to have a mind of their own, they only work when they want to. Most of the time I can move the lever and they will work fine. Sometimes they work but are very sluggish and jumpy. Other times i get nothing at all (usually when its a downpour.) Sometimes still if I have them set on delay they will work for a few minutes then quit. About half the time if I move the lever all the way to high after the have stopped working they will start again, the other half of the time, no go. I've had this problem for over 6 months now. Plz help me :confused:

Buckeye LJ 01-23-2011 12:32 PM

My 98's wipers would work off and on sometimes and if I remember correctly it seemed as though the electrical connections to the wiper motor were a little gummed up. I just moved them around and sprayed some contact cleaner into them and it seemed to take care of the problem. Also sprayed some cleaner into the actual switch on the steering column. Hopefully yours is just a bad connection too!

rday78 01-23-2011 12:36 PM

Had that problem then they stopped all together.... went to get a new motor and they wanted $85. Being the cheap bastard i am i took the cover off the motor to find one of the magnets in the can fell off. I epoxyed it back on and have been good to go ever since.

99wranglertj 01-23-2011 03:43 PM

Thanks for the quick responses, I'll check into both of your solutions next day of nice weather we get. Thanks again!

rday78 01-23-2011 03:49 PM

Easy enough to take apart and worth taking a shot at it before droppin some coin. Seems it a very.common problem with the tj. Looks like water manages to sneek into the motor... would be worth while to put some silicone on the mating surfaces when puttin the motor back together

99wranglertj 01-25-2011 11:15 PM

I'll finally have time to look at it this weekend. I'll let you guys know what I found out, and whether or not it worked. Thanks again for your quick replies!

99wranglertj 02-03-2011 05:10 AM

Well I looked into my problem. I took the connections at the motor and at the switch apart and cleaned them with some connector cleaner. Then I put some Vaseline on the connections to seal them from any moisture. They worked like they are supposed to for about 1 day then they started fouling up again. Sooo any other ideas. I didn't get a chance to pull the motor off to clean the ground, could that be the whole problem? Or is the motor junk?

rday78 02-03-2011 04:02 PM

After i glued the magnet back in it worked well for a few weeks. Then it stopped.and burnt the fuse. Went to autozone and bought one. Too expensive but it has a oifetime warranty so at least i can get a new one if i need it.... and after all the practice i can change one out in about 15 mins lol

Buckeye LJ 02-03-2011 04:48 PM

possibly the ground...if it does turn out to be junk maybe daveysjeeps.com has one for cheap? I don't know but i would guess that they might

99wranglertj 02-04-2011 02:29 AM

I'll have to do a little more detctive work on mine. Check the ground, and check that magnet that rday was talkin about. idk when ill get to it but i'll be sure to let you guys know what i found out. Thanks again.

99wranglertj 09-11-2011 06:14 AM

Ok so I've checked the ground and cleaned it. I've checked the plug to the switch, unplugged and greased it up. I've unplugged and greased the plug to the motor itself and I still have the problem. It's still happening randomly though. That's what has me stumped. Sometimes they will work just like they are supposed to, others they start off fine then quit all of the sudden. Other times they only work on high. I'm wondering if I've got a broken wire somewhere, but it doesn't get fixed or get worse by hitting a bump, it can do it on a smooth freshly paved road. Should I replace the switch and see if that fixes it, or should I try the motor? Ugh! This is the only problem I have with this thing and its so frustrating. I dread electrical work lol. I checked all tuis stuff a couple of months ago, I've just been waiting to see it it would take a while to get better, apparently not.

ALASKA99TJ 09-11-2011 11:29 AM

no dont replace i did that and it changed nothing. after reading thru this im thinking there r motor issues, i need to explore also have the exact same problem.

99wranglertj 09-12-2011 09:06 PM

Well if you get yours done before I get mine done, please let me know what worked. And if I get mine done before I hear from you post it on hear to let you know what fixed mine.

Tackelbarry 09-13-2011 08:37 AM

My wipers were doing the exact same thing. And, I spent the time taking them apart, two seperate times to try and do the same cheap fixes. Then I bought a new wiper motor from NAPA. Basically, I wasted 2 1/2 hours of my life trying to save $90.00. I will not do that again. I can always make more money, but I can never make more time. Just my opinion.

99wranglertj 10-19-2011 08:05 PM

Well the problem was with the motor. It was a rusted pike of crap. I didn't buy a new one though, I went to the junk yard and got one that is tested and so far works without a single problem. Thanks for all you help everyone!


All times are GMT -5. The time now is 05:53 PM.