Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   CJ General Discussion Forum (http://www.wranglerforum.com/f298/)
-   -   wiper blade issues (http://www.wranglerforum.com/f298/wiper-blade-issues-80659.html)

foxinthemudd 02-16-2011 10:16 PM

wiper blade issues
 
need some advice on wiper blades. I know this is an easy fix on most vehicles, but the CJ7 needs some new blades for the wipers. I bought a new set at the store only to find out there is a special connector or something needed to hook them up. can someone please shed some light on this issue. its been frustrating me to no end tonight.

Thanks in advance,
Fox

foxinthemudd 02-22-2011 05:34 PM

seriously... no one has an answer or has had to maybe replace theirs?

Cj7otr 03-03-2011 08:26 PM

My cj is in the shop, but I'll look at the wipers when I get it back. I THINK you simply pull the base of the arm off of the gear, but double check first.

Dempsey 03-03-2011 08:36 PM

I'll look this weekend. I always thought the wipers sucked on my cj. Just use rainx on the glass and tried not to drive in the rain.

Nick

riofebdinan12 03-03-2011 09:29 PM

I THINK you simply pull the base of the arm off of the gear, but double check first.

omilu7 03-22-2011 04:03 PM

I just pulled mines off, there is a small clip on the bottom of the base of the wiper it's shaped like a L. Popped it off with a small screwdriver... Hope this helps

VoodooShot 03-24-2011 07:04 AM

Not all the wiper blades come with the adaptor for the small peg anymore .
I have a YJ and bought a set and had to take them back for a set for the small peg .
Used to be all wipers would come with adaptors for any vehicle.

foxinthemudd 03-29-2011 11:45 PM

Quote:

Originally Posted by VoodooShot (Post 1135296)
Not all the wiper blades come with the adaptor for the small peg anymore .
I have a YJ and bought a set and had to take them back for a set for the small peg .
Used to be all wipers would come with adaptors for any vehicle.

if I remember right this was the issue I was having. it is such a PITA.

It gets even better, after I posted this original post, I was driving home and it started pouring. Now I have about an hours drive, and about 5 minutes after getting on the highway my wipers stopped working!

Turns out the driver side wiper arm bound up from the interior arm connector next to the gear motor, and it started to turn the arm peg so that it bent the metal on the windshield channel!:banghead: its gonna be a bit before I can get to it.
Has anyone had any issues like that before?


All times are GMT -5. The time now is 01:58 PM.